summaryrefslogtreecommitdiff
path: root/net-vpn/i2pd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /net-vpn/i2pd
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'net-vpn/i2pd')
-rw-r--r--net-vpn/i2pd/Manifest2
-rw-r--r--net-vpn/i2pd/i2pd-2.53.0.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/net-vpn/i2pd/Manifest b/net-vpn/i2pd/Manifest
index 0f06d6bd8197..194f4cfaec7d 100644
--- a/net-vpn/i2pd/Manifest
+++ b/net-vpn/i2pd/Manifest
@@ -5,5 +5,7 @@ AUX i2pd-2.39.0.initd 1437 BLAKE2B 6f4e7b585e2acbabdb58999387954cac0ac5edd8bc7c3
AUX i2pd-2.52.0-miniupnp.patch 1198 BLAKE2B 3448fb24ca2c41cf37b15a4c45e8245d0c5dbf535e3945b9f7093585f438b48319dbfd810268690aa4a49a5946a50681842baff63afebdda4dcd2d1f85959130 SHA512 c215df5e32142732f405534ad0fa874e8fa15f18513423f833c60f3d2bc4d143e5cf3065a0602b43636988331175062304996aa47ec0e0aead36a897b7383baa
AUX i2pd-2.6.0-r3.confd 322 BLAKE2B 1abce31d300785fe0f42eb0c15bc26f723e99bfe4f3d21ef4d83620c064838d0e27f89f287a97404276490b848bd1372a40b915d4830b7755d801c4bda551099 SHA512 083f4c860d7556bd14f2765b098743c25f996ef16de3982430ff27ac7711051738d48709654441099ea8c755b6d9a6e25b52286f7e8c928d3f39f1207a9517a9
DIST i2pd-2.52.0.tar.gz 677023 BLAKE2B 785eeb074df3e8a046ae3c6aa1204b52275ced56560addb3d4829d098b22d37582a41de29042bb3b2d48b6616f606c200b16ae10b26608d4bb6b74f237a4c9da SHA512 54272b23dcb62b8b7523038a9c1fc71b87bb9042f22bd12d6ebc62cfa47da07e2df47d88d706f285e9d88f9cace0564546632c10161f83f5c57b9ea17f5bde5f
+DIST i2pd-2.53.0.tar.gz 675583 BLAKE2B e1ebcc4a629bceda276c85c048f4b8048f89ef166045f9b24a4909f96774a4a162475f88466c3e346f0c76ed2151185754a6dd39be693a1850f076905fa2aa8f SHA512 54aaf96e5c1b0536247ed9644b2d5269df770e723307b4538f153de4a301479c5ef40fbfae097a3796f1114d89d7e9bb53715f408b6d32b15f6b31e1a1fdb7df
EBUILD i2pd-2.52.0.ebuild 1997 BLAKE2B fc2b2d9deb7c80d78a53c79801319c962887caf04e1d8b1b8087c243fe060f8dab06cae4339b8c2b467a3918a772c7a80543727f64e97ca5e71a9c6624d1400b SHA512 03a313d13f7bec68c088740fc828e8bc9c33d20d135c87eec103b0c6100a66e219e1d0a8ad52a65b00b8c0236e709e27e76f4353707a93cd5e640f402f730df0
+EBUILD i2pd-2.53.0.ebuild 1954 BLAKE2B 47fc79773f9c76eb391bb3f040a18a9beb66712ae72636ef8c54db836c2a31567579065abbd5aff186a407549c9137b8bc575b61c6e366138ad05f2fba589c4b SHA512 9197177fd3202dad5a9f3f86fd33cf362c10d28c47703d8d22e5e4964d72ffd7da86c309086517bf914dd3ca93b118ed2d4694cb7840a11dbb9a29bd20fef80d
MISC metadata.xml 588 BLAKE2B a7a342599b07b88c0fc192386a7722eeb864b8f1debc4f30d6825e829b9c684d085edc6ef0b4e7d8e5bf3e04e93629df2925341784b2221d591084098a8a2d3e SHA512 86ca6c50c7eb8f06269a3e0b84f1189f4be57f40ea92b9cae3b9299b02c63d5a89fbb9ca6f16588a682ea1bb193c6395b55f67799c07e4bbf60f046185fb5d0e
diff --git a/net-vpn/i2pd/i2pd-2.53.0.ebuild b/net-vpn/i2pd/i2pd-2.53.0.ebuild
new file mode 100644
index 000000000000..cb442b9d45f9
--- /dev/null
+++ b/net-vpn/i2pd/i2pd-2.53.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs systemd
+
+DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
+HOMEPAGE="https://github.com/PurpleI2P/i2pd"
+SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_x86_aes i2p-hardening +upnp"
+
+DEPEND="
+ dev-libs/boost:=
+ dev-libs/openssl:0=[-bindist(-)]
+ sys-libs/zlib
+ upnp? ( net-libs/miniupnpc:= )
+"
+RDEPEND="
+ acct-user/i2pd
+ acct-group/i2pd
+ ${DEPEND}
+"
+
+CMAKE_USE_DIR="${WORKDIR}/${P}/build"
+
+DOCS=( ../README.md ../contrib/i2pd.conf ../contrib/tunnels.conf )
+
+pkg_pretend() {
+ if use i2p-hardening && ! tc-is-gcc; then
+ die "i2p-hardening requires gcc"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
+ -DWITH_HARDENING=$(usex i2p-hardening ON OFF)
+ -DWITH_STATIC=OFF
+ -DWITH_UPNP=$(usex upnp ON OFF)
+ -DWITH_LIBRARY=ON
+ -DWITH_BINARY=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # config
+ insinto /etc/i2pd
+ doins contrib/i2pd.conf
+ doins contrib/tunnels.conf
+
+ # working directory
+ insinto /var/lib/i2pd
+ doins -r contrib/certificates
+
+ # add /var/lib/i2pd/certificates to CONFIG_PROTECT
+ doenvd "${FILESDIR}/99i2pd"
+
+ # openrc and systemd daemon routines
+ newconfd "${FILESDIR}/i2pd-2.6.0-r3.confd" i2pd
+ newinitd "${FILESDIR}/i2pd-2.39.0.initd" i2pd
+ systemd_newunit "${FILESDIR}/i2pd-2.38.0.service" i2pd.service
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/i2pd-2.38.0-r1.logrotate" i2pd
+}
+
+pkg_postinst() {
+ if [[ -f ${EROOT}/etc/i2pd/subscriptions.txt ]]; then
+ ewarn
+ ewarn "Configuration of the subscriptions has been moved from"
+ ewarn "subscriptions.txt to i2pd.conf. We recommend updating"
+ ewarn "i2pd.conf accordingly and deleting subscriptions.txt."
+ fi
+}