summaryrefslogtreecommitdiff
path: root/net-voip/sipvicious/sipvicious-0.3.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-voip/sipvicious/sipvicious-0.3.3.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-voip/sipvicious/sipvicious-0.3.3.ebuild')
-rw-r--r--net-voip/sipvicious/sipvicious-0.3.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-voip/sipvicious/sipvicious-0.3.3.ebuild b/net-voip/sipvicious/sipvicious-0.3.3.ebuild
new file mode 100644
index 000000000000..08e0cb65695f
--- /dev/null
+++ b/net-voip/sipvicious/sipvicious-0.3.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="SIPVicious is a SIP security package"
+HOMEPAGE="https://github.com/EnableSecurity/sipvicious/wiki"
+SRC_URI="https://github.com/EnableSecurity/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ sed -re 's:man/man1:share/man/man1:' -i setup.py || die "Error updating man page installation location."
+}