summaryrefslogtreecommitdiff
path: root/net-proxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /net-proxy
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/Manifest.gzbin5367 -> 5364 bytes
-rw-r--r--net-proxy/mitmproxy/Manifest2
-rw-r--r--net-proxy/mitmproxy/mitmproxy-7.0.4.ebuild69
3 files changed, 71 insertions, 0 deletions
diff --git a/net-proxy/Manifest.gz b/net-proxy/Manifest.gz
index 0e5819ce8161..f3371ad10aa9 100644
--- a/net-proxy/Manifest.gz
+++ b/net-proxy/Manifest.gz
Binary files differ
diff --git a/net-proxy/mitmproxy/Manifest b/net-proxy/mitmproxy/Manifest
index 06748e03de0a..1a146f557378 100644
--- a/net-proxy/mitmproxy/Manifest
+++ b/net-proxy/mitmproxy/Manifest
@@ -1,3 +1,5 @@
DIST mitmproxy-7.0.3.tar.gz 27311502 BLAKE2B a55f8a43cc052e342a0630fdd80fc713be7ce3db7b3899ccce79cfcd385345b7ebe8480c618c626d63e851d92f528a350d614ac3c7dfb85b01a555389d914ff7 SHA512 cffbb60421724fa28aab69b3bf1100e0aa5ab6e8933186f5706eb4eee35ef0f716616001156dac07921c73024e6ad8b98499a273575c592bb7694c0dffb728da
+DIST mitmproxy-7.0.4.tar.gz 27312748 BLAKE2B a23db472adab33db615b0daa93694211450e8899885dc75601d40a4964cc505437db6a106622eb8051263db23280261134937b6567482dd584eed29cc592e42b SHA512 4224b44e609f84b974b5419c6ceb576845957968c786ee437bffb5fa5df685ce0712d5ef8c402d40c568406242f44692cc7f04037fadd19ecece8b112d73b7ae
EBUILD mitmproxy-7.0.3.ebuild 2167 BLAKE2B b60531fb28c28b5e5a148a1c6b3ec5ee8b5a6198e59ff0d244416530bba8f7820e929d7f7bee879b5a602d76c58801d3077b3f02e281dffd6b8fa1d820190fc4 SHA512 728430ef35e34f350cf70a5347232cf7c19bf84ccfacf919dbbde4d8dad7d3b672d181212bda81df1eae0c5bc93693dd74f70cc95a65b2b40d64a6d3ef872717
+EBUILD mitmproxy-7.0.4.ebuild 2168 BLAKE2B 46b0534502f8b9b0cd2ad7c216a4f3857dd7d7d34ae6e6bf1422753d9124516842c33ccccdd51b9e89321229f436e0a1805e2e9bbd1386bb82456e5fbda1817a SHA512 6af55ca6c6447444e62c47594b23acd1c3cb918aa2ff2b5e926009fc99814afa21c0aac1d7f3e3dbfbbde9e5489469cbc5c6a15b5cc3ded2c521f52d5517c49f
MISC metadata.xml 1066 BLAKE2B 3422f5161cf706d9361875fd86d165425717f5756a530290e1b739703dc3b2088701838378d91463a8038925c5e8e95c0f69a3d5104441988c3ad7cfd8364b82 SHA512 740d3f498579906f42fcaa2a711fab7a4f04488ef1864850410de610d691509296691144e6a74a8c13b9ba9df4bb7dad08a3836aff016aac2a05a9efd4525c87
diff --git a/net-proxy/mitmproxy/mitmproxy-7.0.4.ebuild b/net-proxy/mitmproxy/mitmproxy-7.0.4.ebuild
new file mode 100644
index 000000000000..0abdfc2548cf
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-7.0.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="https://mitmproxy.org/"
+SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.0[python,${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/h2-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ldap3-2.8[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-20.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.16[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.3.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.11.0[${PYTHON_USEDEP}]
+ dev-libs/openssl:0
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-5.8[${PYTHON_USEDEP}]
+ >=dev-python/parver-0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # loosen dependencies
+ sed -i \
+ -e '/>/s/>.*/",/g' \
+ -e '/python_requires/d' \
+ setup.py || die
+
+ # remove failing test
+ sed -i 's/test_get_version/_&/g' test/mitmproxy/test_version.py || die
+
+ distutils-r1_python_prepare_all
+}