summaryrefslogtreecommitdiff
path: root/net-proxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-30 09:24:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-30 09:24:14 +0100
commiteba9b95ba8976f2938bafa5789c1b50611bb3459 (patch)
tree36f155db1521abbf4398c0f9b1f90044de53ef48 /net-proxy
parentd70b0f920e70eb6f0a26d9ed3767e27a73c74678 (diff)
gentoo auto-resync : 30:09:2022 - 09:24:13
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/Manifest.gzbin5362 -> 5363 bytes
-rw-r--r--net-proxy/squid/Manifest2
-rw-r--r--net-proxy/squid/squid-5.7.ebuild27
3 files changed, 17 insertions, 12 deletions
diff --git a/net-proxy/Manifest.gz b/net-proxy/Manifest.gz
index 62e3233b8914..3bc36c671939 100644
--- a/net-proxy/Manifest.gz
+++ b/net-proxy/Manifest.gz
Binary files differ
diff --git a/net-proxy/squid/Manifest b/net-proxy/squid/Manifest
index a57068e1acbb..0a1fc13789e2 100644
--- a/net-proxy/squid/Manifest
+++ b/net-proxy/squid/Manifest
@@ -14,5 +14,5 @@ DIST squid-5.7.tar.xz 2566560 BLAKE2B 4a403ca4f94034356922ea1a4feffd5f5289e2aadb
EBUILD squid-4.15-r3.ebuild 8015 BLAKE2B 219a853661c70d8797424bd6461964193b2ad1f173141e546630ba190b61f39a4e89a335db2a6fd184242ecf9bc8fe14b60397a70a865179838f77a0df1ec171 SHA512 ce47b241e6e9fb945214e74439fc94fb0ee68dd024baf8540595ccdd9ef4f246419c09039360b1ba6beab1b2fbc2e8756bc104cb4351e01ce0a3859be21bfcf0
EBUILD squid-4.17-r1.ebuild 8181 BLAKE2B 4dc3dbebaba4e6f9035a522b92ace1989648957adb4d1c9d614672f8da16a3a9b13dc9ca8378ed2ef00e0aa61ec8a78d639273a9ffcae623a20429297833bf81 SHA512 ad1db57edee84935bfce4dc665bb19115e5b7c06630403284148d569db9ee735527a021311f92cda208c528b96924d2ab4487dd5a966833100cc0b593cea1fa2
EBUILD squid-5.4.1-r2.ebuild 8248 BLAKE2B c139a046e67cc733c851dd32d29eb339f5ca205bc1b9a0da405fbe0795c76bf061acd049955cc810fc0293e869cb3efeb8620a6c53d56776280545acc5ad03d1 SHA512 f6af01ce4d442a5b18d4a5f824772c3682613fd8e673bd907cf33e7b2c0b34870ca6ed18d46eda7549b31266eea9a8c09576417ef67735749f9abd593557e183
-EBUILD squid-5.7.ebuild 8810 BLAKE2B 6c4b08ed0f0e5427d501d13d494e14f508a3fde5ceb2a18a7511c52e18cc5241e417aecc49cfe171625acb831e0430eb63a4e4c143ff32eedd8c0edf767a9bc9 SHA512 aa71dcb7e976e719ce7adf21634549a6db895e6e782e22e813d226dfb1bec8df9b93586d03b21d9933734d5ec03a30559603b8fa0115e138c53c204cd2c7ea6a
+EBUILD squid-5.7.ebuild 8976 BLAKE2B 036facf09ada31bfcca73131f47646ac07f6b8aee73e4baf3460592a4e2067def5c802d7ef0ba4b68e3d6f6df28b78c235e0ebae0757196e28cf12a012583e23 SHA512 ffc64b6fc1056ab5c906bb1398a07ecb77f620f452c9e1de40553a52544be3d6f7233d5b612c67d09608127a91deb0560037a436e16e862f7cdbc87b97b13f8d
MISC metadata.xml 1178 BLAKE2B ef1e50d591c080e753b2eded1cb9934d26f46358125188ae539489e7bcaa787862c177e3a72f48217ade968fa1bf7870fb0420ae8fc214cc142522a9bf2675f2 SHA512 72db9b79e1861ccd78df889cd5d95e17fdfdc55846b1f3a21171ff5b24ddada441dc807dc818086689b3c20b9e53e6cbc83abfc5afdaea6d744b486e519b6d64
diff --git a/net-proxy/squid/squid-5.7.ebuild b/net-proxy/squid/squid-5.7.ebuild
index f3ad18c4f62d..30aee5f4ebdc 100644
--- a/net-proxy/squid/squid-5.7.ebuild
+++ b/net-proxy/squid/squid-5.7.ebuild
@@ -205,6 +205,8 @@ src_configure() {
myeconfargs+=( --without-mit-krb5 --without-heimdal-krb5 )
if use kerberos; then
+ # We intentionally overwrite negotiate_modules here to lose
+ # the 'none'.
negotiate_modules=( kerberos wrapper )
if has_version app-crypt/heimdal; then
@@ -221,10 +223,13 @@ src_configure() {
fi
# NTLM modules
- local ntlm_modules=(
- none
- $(usev samba 'SMB_LM')
- )
+ local ntlm_modules=( none )
+
+ if use samba ; then
+ # We intentionally overwrite ntlm_modules here to lose
+ # the 'none'.
+ ntlm_modules=( SMB_LM )
+ fi
# External helpers
local ext_helpers=(
@@ -240,7 +245,7 @@ src_configure() {
use ldap && use kerberos && ext_helpers+=( kerberos_ldap_group )
if use mysql || use postgres || use sqlite; then
- ext_helpers+=( SQL_session )
+ ext_helpers+=( SQL_session )
fi
# Storage modules
@@ -282,12 +287,12 @@ src_configure() {
}
myeconfargs+=(
- --enable-storeio=$(print_options_without_comma "${storeio_modules[@]}" )
- --enable-auth-basic=$(print_options_without_comma "${basic_modules[@]}" )
- --enable-auth-digest=$(print_options_without_comma "${digest_modules[@]}" )
- --enable-auth-ntlm=$(print_options_without_comma "${ntlm_modules[@]}" )
- --enable-auth-negotiate=$(print_options_without_comma "${negotiate_modules[@]}" )
- --enable-external-acl-helpers=$(print_options_without_comma "${ext_helpers[@]}" )
+ --enable-storeio=$(print_options_without_comma "${storeio_modules[@]}")
+ --enable-auth-basic=$(print_options_without_comma "${basic_modules[@]}")
+ --enable-auth-digest=$(print_options_without_comma "${digest_modules[@]}")
+ --enable-auth-ntlm=$(print_options_without_comma "${ntlm_modules[@]}")
+ --enable-auth-negotiate=$(print_options_without_comma "${negotiate_modules[@]}")
+ --enable-external-acl-helpers=$(print_options_without_comma "${ext_helpers[@]}")
)
econf "${myeconfargs[@]}"