summaryrefslogtreecommitdiff
path: root/net-proxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-05 20:08:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-05 20:08:35 +0100
commit35bf81c760d4e362615c32e69329ef61a01281f7 (patch)
treeb1a0fef96c609a4ff2ca6e27d2c92a1001927485 /net-proxy
parentaa47868356ed14c3fc4d9500eae0469f2250ddb1 (diff)
gentoo auto-resync : 05:08:2022 - 20:08:35
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/Manifest.gzbin5364 -> 5368 bytes
-rw-r--r--net-proxy/hatop/Manifest2
-rw-r--r--net-proxy/hatop/hatop-0.8.2.ebuild31
3 files changed, 33 insertions, 0 deletions
diff --git a/net-proxy/Manifest.gz b/net-proxy/Manifest.gz
index b4e9a36bcd7c..58fca9e7b204 100644
--- a/net-proxy/Manifest.gz
+++ b/net-proxy/Manifest.gz
Binary files differ
diff --git a/net-proxy/hatop/Manifest b/net-proxy/hatop/Manifest
index 0eccbe639312..02dae525a179 100644
--- a/net-proxy/hatop/Manifest
+++ b/net-proxy/hatop/Manifest
@@ -1,3 +1,5 @@
DIST hatop-0.8.1.tar.gz 136760 BLAKE2B 3692e9dd307d5f098bd3a66a3a75be5184e17d246dc94b3581d2742c9629d558dc4768baaef1c1e290825e57a651dccc926f22b4ecc98074cc8309fdda4b4b57 SHA512 25026ddd62ef43f02cfb3ef41a815adf232c8a4b3053e925dcea69696c207ffbf22966ce1177ef460071e683f5a4ec8d011d2bb2b0aa06f4a9b3e5932aae93b6
+DIST hatop-0.8.2.tar.gz 138013 BLAKE2B c4a86952bf892ad989c6a28aa4bec503b24cbd11ec78cc9fb89625e30f7b1d39c0f8929018df03e7c8906d1b478f31be1003b0c37be0d09916787e1825780a60 SHA512 5e772394d72962bdd014f93ee94ea59814cee33e17c1864af5b3ec97a19c2c33a6ad13f24d0cf0baf78335d9a82cee28b60a03754430b0aa9132c1dd92753cdb
EBUILD hatop-0.8.1.ebuild 666 BLAKE2B 0404a7a4c04d4d804bb86b6f712cdccb016aeb5d7ca23d5c62d89a8c14431087eabc79ffded1241766376235e78c312e74232b09237806f6868b260c376f0456 SHA512 1440b1ee3ee8126d10870d0ffbb6bb71db6eef66781174a5a72dc6c439e13635389ce3abf75e0a1dc205d69c69417dc7e4d667c8fa9cc5aaaf0d8e3bd0ac34a9
+EBUILD hatop-0.8.2.ebuild 666 BLAKE2B 0404a7a4c04d4d804bb86b6f712cdccb016aeb5d7ca23d5c62d89a8c14431087eabc79ffded1241766376235e78c312e74232b09237806f6868b260c376f0456 SHA512 1440b1ee3ee8126d10870d0ffbb6bb71db6eef66781174a5a72dc6c439e13635389ce3abf75e0a1dc205d69c69417dc7e4d667c8fa9cc5aaaf0d8e3bd0ac34a9
MISC metadata.xml 250 BLAKE2B 127d3b63d96953a7263c1ecb0f0cd905cbba9006349ae20351476072eb08aa6e5d0da402e3a90fea218e2e05971096bbfd13d2bb6f57221d8772885075dc6523 SHA512 a8423fb0d09057a311f01b4fe8bc03d0535b701a96846a7617e9ea61d7aa3ccd7e8de31451488a7db435e8f8178a5dd70e5511080eccee8880d6959d9de4c0d5
diff --git a/net-proxy/hatop/hatop-0.8.2.ebuild b/net-proxy/hatop/hatop-0.8.2.ebuild
new file mode 100644
index 000000000000..15c530c52d75
--- /dev/null
+++ b/net-proxy/hatop/hatop-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_REQ_USE="ncurses"
+
+inherit python-r1
+
+DESCRIPTION="Ncurses client and real-time monitoring and displaying of HAProxy status"
+HOMEPAGE="https://github.com/jhunt/hatop"
+SRC_URI="https://github.com/jhunt/hatop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python_foreach_impl python_doscript bin/hatop
+
+ doman man/hatop.1
+
+ dodoc CHANGES.rst KEYBINDS README.rst
+}