summaryrefslogtreecommitdiff
path: root/net-proxy/sshuttle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /net-proxy/sshuttle
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'net-proxy/sshuttle')
-rw-r--r--net-proxy/sshuttle/Manifest2
-rw-r--r--net-proxy/sshuttle/sshuttle-1.1.0.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index addb73058dfc..832028ca38a4 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1,3 +1,5 @@
DIST sshuttle-1.0.5.tar.gz 88823 BLAKE2B 6a68be71a92c8245e2e60df1f425c6959547f8c2b972bdafcd774449c3779698c2549f2c7a3575c102158962ef9dd2edaaecec564f36f7f5cc84ed3f53b3daa3 SHA512 a9ebc8f8cf5ccc351796c2eb5b224b5d76908d23a367b768fa4e7b9cd8517ee7ff9c232c92ed4332f46d02d890ad8114f8beaa66876a8c0d7d4850c18ff4c2b3
+DIST sshuttle-1.1.0.tar.gz 93987 BLAKE2B c81ab591d5f84764a6ed114623ccb1aaf2ff9706bc5f494513b19c4c2eeb218f3777b2bc7042329eb862aa311a5eab56669d88e10d92b019c0ff9ac9381e3903 SHA512 86361dec179c2ae61c338abaec3d0d36a280c1cc719c1df245a98379037315ac71781e8e5599bb50e34f5068dab3e1010cd7d15c614e01f3dc12011b620d43ee
EBUILD sshuttle-1.0.5.ebuild 1220 BLAKE2B 6fd16d277f5a00ff339697629860908464aedbfa778ad019a4e7cd682e145bd0aad6d044b643e4fcf56ad6a0e0a2193119cab3e08dd43ad0203c34215edac064 SHA512 41e5d28a26a6e27ace9f42b874fcd2a5d1be205e70d85519e5f34aa0adb9f947172876ad737b49d34d32240a6370eab9d00ba2e539c72def9ec7484cd07c7f3d
+EBUILD sshuttle-1.1.0.ebuild 1254 BLAKE2B ed006f69db8a8c4007c782cd8a697c97b13dde54bf983c3e9b50b061173c435f07b69df49eece85737b1f61bffea71683513acaaa3cee602ba7f3a6164951fdf SHA512 7caa62265e1d2847319500d8dd719becf585b2dcb5d0db822221e4f3d47edd1229ed00e510fa4f2cb7d00ce47592a60c32a3857c328918be71c69ea5af7f67e4
MISC metadata.xml 368 BLAKE2B 8781826aa94f38296cb3c0ef628c931875cf7d8c1f3080970be16c3dd01862d067d4051f4d2c271bc63dd9260c4652ba5fd48002eb5747eab68ba9f02a6a3629 SHA512 a4609eb161d14b0b12d93406a257774465e377c432731cd6d72267baa3396545f45e5df9a16577ff143254797e872aa988213af190d47134d9f09de8d820b6d2
diff --git a/net-proxy/sshuttle/sshuttle-1.1.0.ebuild b/net-proxy/sshuttle/sshuttle-1.1.0.ebuild
new file mode 100644
index 000000000000..809e9d48926c
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-1.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.org/project/sshuttle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/sphinx
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ || ( net-firewall/iptables net-firewall/nftables )
+"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~NF_NAT"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Don't run tests via setup.py pytest
+ sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
+
+ # Don't require pytest-cov when running tests
+ sed -i "s/^addopts =/#\0/" setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -j1 -C docs html man
+}
+
+python_install_all() {
+ HTML_DOCS=( docs/_build/html/. )
+
+ doman docs/_build/man/*
+
+ distutils-r1_python_install_all
+}