summaryrefslogtreecommitdiff
path: root/net-proxy/sshuttle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /net-proxy/sshuttle
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'net-proxy/sshuttle')
-rw-r--r--net-proxy/sshuttle/Manifest2
-rw-r--r--net-proxy/sshuttle/sshuttle-0.78.5.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/net-proxy/sshuttle/Manifest b/net-proxy/sshuttle/Manifest
index b5535be33340..575fc9416fc7 100644
--- a/net-proxy/sshuttle/Manifest
+++ b/net-proxy/sshuttle/Manifest
@@ -1,3 +1,5 @@
DIST sshuttle-0.78.4.tar.gz 72465 BLAKE2B 655df610757e245b66db61955306908c8d1e41db7d093dc44d55260a34b30d4605973815c64d59a860974e9a268e3fcefbba41a104da5ad73f6a8a292bc64b80 SHA512 6e3e49a638ad56fbb00b197d33426f9ccb9afe3d71f8109eb886bc9047083100c910fef7cb42f0426246e585138ce996872179d23fca98afd9e9ccca376da1e6
+DIST sshuttle-0.78.5.tar.gz 74663 BLAKE2B 47e295219c1ada7bee4f0340cc169620c5b91abd1f72b933289ef2dea0c5ba088673f2d1348d444f662e9f6c2638ee6dfd3e8df1fa8344bc7c48adf1a3a96d3f SHA512 562acbf0e825ad41458c5b6065592a45b8bac92cd64b20619027fe4d0bec60a22c5191c7a7ed6b216d8cf5c9e027f58a6cdca69dd3a11ec6f6d348ef2f13bb38
EBUILD sshuttle-0.78.4.ebuild 1278 BLAKE2B 943cb741fdba4de960022d341e64eb75e9b78fea65c46c243b85321faf6d81d0c41ead95db8a766c5b7879f9bb71eddd6114a5653f2ea2d9d53d7895088e2230 SHA512 35df645c112c1a2b5cf2f055e321cac5ed699d051590aff9e132814a64f8eea7c312353ca2e439582d163925fe2448585081bac1240ce8df5dfaf60a32396084
+EBUILD sshuttle-0.78.5.ebuild 1266 BLAKE2B cd60e5d6f3a1e643f155f3b295a800de61e9a66663460ee70d6fab4256a7418280a2a28b9219044601e4258d47fe4f3bf97d102231f62ffa50a430d1fba7ce25 SHA512 fb306acd5f666db91e4e1227de4033bbad97609e64dcdad00c4937f0b8ead9d606770bf087b947ecef4a9dffa493869daac40ee0d2fb1ef71bcb3cf31d4d322c
MISC metadata.xml 386 BLAKE2B 5a94094f59d57f94569067c3ef424b46cec97b8c6f552422ca4b5baa910f9b5f547215c49647f8e2b4ab7f008abc57e4fc407f38f8fab252d17dfb072993a496 SHA512 988f65a4a15eac0630b83d0e090749c12ef58ca1284ed94f45f6eb9c4a5ff0678a481519f435a992f572b98a8878fbfeb7bf573443c128cd29e5c365a8eb2e32
diff --git a/net-proxy/sshuttle/sshuttle-0.78.5.ebuild b/net-proxy/sshuttle/sshuttle-0.78.5.ebuild
new file mode 100644
index 000000000000..ef640caf7803
--- /dev/null
+++ b/net-proxy/sshuttle/sshuttle-0.78.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit linux-info distutils-r1
+
+DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
+HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.org/project/sshuttle/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ || ( net-firewall/iptables net-firewall/nftables )
+"
+DEPEND="
+ dev-python/sphinx
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~NF_NAT"
+
+python_prepare_all() {
+ # don't run tests via setup.py pytest
+ sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -j1 -C docs html man
+}
+
+python_test() {
+ py.test -v || die "Tests fail under ${EPYTHON}"
+}
+
+python_install_all() {
+ HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}