summaryrefslogtreecommitdiff
path: root/net-proxy/sshuttle/sshuttle-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /net-proxy/sshuttle/sshuttle-1.0.5.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'net-proxy/sshuttle/sshuttle-1.0.5.ebuild')
-rw-r--r--net-proxy/sshuttle/sshuttle-1.0.5.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-proxy/sshuttle/sshuttle-1.0.5.ebuild b/net-proxy/sshuttle/sshuttle-1.0.5.ebuild
index 888000fa91a9..5cc44739a206 100644
--- a/net-proxy/sshuttle/sshuttle-1.0.5.ebuild
+++ b/net-proxy/sshuttle/sshuttle-1.0.5.ebuild
@@ -32,10 +32,10 @@ CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~N
distutils_enable_tests pytest
python_prepare_all() {
- # don't run tests via setup.py pytest
+ # Don't run tests via setup.py pytest
sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
- # don't require pytest-cov when running tests
+ # Don't require pytest-cov when running tests
sed -i "s/^addopts =/#\0/" setup.cfg || die
distutils-r1_python_prepare_all
@@ -47,6 +47,14 @@ python_compile_all() {
python_install_all() {
HTML_DOCS=( docs/_build/html/. )
- doman docs/_build/man/*
+
+ # Sphinx 4.0 changed the layout for installed man pages
+ # https://bugs.gentoo.org/789417
+ if has_version '>=dev-python/sphinx-4.0.0' ; then
+ doman docs/_build/man/1/*
+ else
+ doman docs/_build/man/*
+ fi
+
distutils-r1_python_install_all
}