summaryrefslogtreecommitdiff
path: root/net-proxy/ratproxy/ratproxy-1.58.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-proxy/ratproxy/ratproxy-1.58.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-proxy/ratproxy/ratproxy-1.58.ebuild')
-rw-r--r--net-proxy/ratproxy/ratproxy-1.58.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-proxy/ratproxy/ratproxy-1.58.ebuild b/net-proxy/ratproxy/ratproxy-1.58.ebuild
new file mode 100644
index 000000000000..72235cfd104c
--- /dev/null
+++ b/net-proxy/ratproxy/ratproxy-1.58.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A semi-automated, largely passive web application security audit tool"
+HOMEPAGE="https://code.google.com/p/ratproxy/"
+SRC_URI="https://ratproxy.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:keyfile\.pem:/usr/share/${PN}/&:" ssl.c
+ sed -r -i -e "s:(ratproxy-back\.png|messages\.list):/usr/share/${PN}/&:" ratproxy-report.sh
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN}-report.sh || die "install failed"
+ dobin ${PN} || die "install failed"
+ dodoc doc/{README,TODO}
+ insinto /usr/share/${PN}
+ doins keyfile.pem ratproxy-back.png messages.list
+}