summaryrefslogtreecommitdiff
path: root/net-proxy/mitmproxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 15:09:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 15:09:59 +0000
commitbe524496e3171d5eab8c56570dd4342a880c3264 (patch)
tree7141abc4a70431332a0a63b8814cc5f06ac64f4f /net-proxy/mitmproxy
parent1ab8c7f6ed10f981d767a0acc2f420cf86775f12 (diff)
gentoo auto-resync : 02:11:2022 - 15:09:58
Diffstat (limited to 'net-proxy/mitmproxy')
-rw-r--r--net-proxy/mitmproxy/Manifest2
-rw-r--r--net-proxy/mitmproxy/mitmproxy-9.0.1.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/Manifest b/net-proxy/mitmproxy/Manifest
index 389dd5e509f9..5a076d5b3563 100644
--- a/net-proxy/mitmproxy/Manifest
+++ b/net-proxy/mitmproxy/Manifest
@@ -1,3 +1,5 @@
DIST mitmproxy-8.1.1.gh.tar.gz 27943959 BLAKE2B e920ee016f3c2c1ece08924e895848d6716c60ed65ba3b0b3ac6c966cf4ac4245a31b31365d248f4b88130f787c65183943eec3611db900a4f5c2e16709c775c SHA512 a62a45f8991819202115ab8f43d1c113df88504c494c73917ec2e3c52999dbe3ac596444a4c096619d4285f2e26a91ec715d6894fc4d7768bac1a2c3c4c268bc
+DIST mitmproxy-9.0.1.gh.tar.gz 29461514 BLAKE2B 291f9846afde35e70a3e900de811d8bd83cdd604ac4a43dbb3d0763d7326d7bdcfc37a0eddc8bf4a145963a61dc9d9956265afad2f9255a993e821ebd7a78b09 SHA512 601d9171f48d93fbc6f002a1dc243c2f358186059e491490ffe5ab7be797e8e622fdb5a9e2fdab10fac7350057f9e9491952527d600477c841c9b5102a045bc1
EBUILD mitmproxy-8.1.1.ebuild 2213 BLAKE2B aa57bccfc16eff33f6ceb482eefb2a7390833fc3e5651dae0df6ba1ca03617707b25f61b01c0e87c4944c3063bb48e2bb25cd9d0d4b200512c5bf08c657a7b8b SHA512 e71817fa9cc153ab58d62733525f55d8c8f1c08e174714d363dd61b7f86c73286bb5138657f49862c07d59c3ba122f264aa1fc568d7dd48052d34e131525d875
+EBUILD mitmproxy-9.0.1.ebuild 2372 BLAKE2B bfe9b63f74cebba5b5622913b5cda2677188dd8a0856a8aa636f90bff1d096e35cf581a011489fea43c6dfc77940ccbd6d16dacc386922c05c399e9f3ba2fbbd SHA512 bd0840d8c5cd173504e2f840d2238d269e6af63c9df4e188dcc3797bed5c91c4bd2ec7cb2fa8d129641e1c039cfdccf783c9863ac0b060b86aa666f79ec1bb9e
MISC metadata.xml 923 BLAKE2B 00d3790b8e1810b193babedab5b14f35c1275c5d544b4ae031cab41e886bb55130a5187a02a0adab6b00c1ad6d38ba485f9ebd68422549e4e4b62a21b7bcdc13 SHA512 50d52876c7f9d71b2cc31a697cec73c8cce041076c8057e9e3e1f0b2218b883898735f545f85f4e28ab1bd2f8091b764ebc6c92e98c291962cb6f1d52e5aa605
diff --git a/net-proxy/mitmproxy/mitmproxy-9.0.1.ebuild b/net-proxy/mitmproxy/mitmproxy-9.0.1.ebuild
new file mode 100644
index 000000000000..1a9ec3e34e78
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-9.0.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9,10} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="https://mitmproxy.org/"
+SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.0[python,${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-37.0.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/h2-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/kaitaistruct-0.10[${PYTHON_USEDEP}]
+ >=dev-python/ldap3-2.8[${PYTHON_USEDEP}]
+ >=dev-python/mitmproxy_wireguard-0.1.16[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-22.1[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/python-zstandard-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.16[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-1.0.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5.8[${PYTHON_USEDEP}]
+ >=dev-python/parver-0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # loosen dependencies
+ sed -i \
+ -e '/>/s/>.*/",/g' \
+ -e '/python_requires/d' \
+ setup.py || die
+
+ # remove failing test
+ # sed -i 's/test_get_version/_&/g' test/mitmproxy/test_version.py || die
+
+ # seems to hang. other tests ensure that mitmproxy_wireguard module
+ # loads properly.
+ sed -i 's/test_wireguard/_&/g' \
+ test/mitmproxy/proxy/test_mode_servers.py || die
+
+ distutils-r1_python_prepare_all
+}