summaryrefslogtreecommitdiff
path: root/net-proxy/mitmproxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /net-proxy/mitmproxy
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'net-proxy/mitmproxy')
-rw-r--r--net-proxy/mitmproxy/Manifest2
-rw-r--r--net-proxy/mitmproxy/mitmproxy-7.0.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/net-proxy/mitmproxy/Manifest b/net-proxy/mitmproxy/Manifest
index cc3fbf1a32ad..852eb86de994 100644
--- a/net-proxy/mitmproxy/Manifest
+++ b/net-proxy/mitmproxy/Manifest
@@ -1,3 +1,5 @@
DIST mitmproxy-6.0.2.tar.gz 27274682 BLAKE2B 146fc4cd376e4ff02d13bf168b26868c5a33b47b30e678fb6d97df36c4b8ec9e8b9ca6e864e56c3943b231a2f2745c1abd7c58814ddf712113c2a20704a6964f SHA512 27eb5e9736891148b5ebec963a2d18de6a69b44428538d2ed1cf9a1dcdd7cbcdeeed662edb2d25521098374e2f9a29b5bb8fba8da4f77ac0d32bf7881ac70d61
+DIST mitmproxy-7.0.0.tar.gz 27308204 BLAKE2B bea89db0dd39a8b3bd516d2e7c2868d4c226afdc78974ce0f88c055fcb4f907e398922c725cd93d344450e3e7e107c23c63ef6a60d19bff48400f6eeb4d0af0a SHA512 3836a33e5d2be09fb89987d2b0b898183dab9f17b990b98ab754d07cc5d7275786cfac0ab946e65a099ece054c7bbd65d62d01e4e4281e5f9b5f3dcdd0ac80b4
EBUILD mitmproxy-6.0.2.ebuild 3046 BLAKE2B e943a273e580e36956e75e794b9848f6206d6a4b111f3e8c398e1ae2e8af23a6e358519ff18219f649f2834ec6dbd843f85a4031253fdf8348063d099a038102 SHA512 a2770f8d6222a509c2d3e0e6b30fe49db2105ef9b35beba460fa9ce309a7f657b8606f7c23a4dcbae08e3d0bc20da15802077a25959bc0c76d5fc54b4a087d66
+EBUILD mitmproxy-7.0.0.ebuild 2207 BLAKE2B d5a5c2ffc3bb7bfd699f2a9ca8daefa24a72f3edba0da8de41473e474fdd443d2738cb102c57658ab3c47809ef8706905e54bcabc2d1946d5af6ff63a0074c89 SHA512 23cd1a66a9f46437b00c8e1c0bca40f27cfe16bc3c0bf28d4cea2fc78fad7a9f700d0186404b54c01336b11d0569c9758f04ffc9d2624b124f2083373330485d
MISC metadata.xml 1065 BLAKE2B 55b5f921dc3e44fe0b1b1a0957fe579d2c358996e4a0f6fcd352303e93749859474e56d639a4cd9f6ef152588c445a7bc88b58841209f6c64761a77f61865e31 SHA512 f5042a78818a1e00fb2157919aa9c6918a953fa55d775b8fd52f6549cbeefc138fd525c9c885186b4b047efb2c5b4d46e74cbc93edd3280a4220fc49b3a7f4e5
diff --git a/net-proxy/mitmproxy/mitmproxy-7.0.0.ebuild b/net-proxy/mitmproxy/mitmproxy-7.0.0.ebuild
new file mode 100644
index 000000000000..1476b80c35f6
--- /dev/null
+++ b/net-proxy/mitmproxy/mitmproxy-7.0.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1
+
+DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
+HOMEPAGE="https://mitmproxy.org/"
+SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=app-arch/brotli-1.0.0[python,${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/hyper-h2-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ldap3-2.8[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-20.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.16[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.3.0[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/wsproto-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.11.0[${PYTHON_USEDEP}]
+ dev-libs/openssl:0
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-5.8[${PYTHON_USEDEP}]
+ >=dev-python/parver-0.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # loosen dependencies
+ sed -i \
+ -e '/>/s/>.*/",/g' \
+ -e '/python_requires/d' \
+ setup.py || die
+
+ # remove failing test
+ sed -i 's/test_get_version/_&/g' test/mitmproxy/test_version.py || die
+
+ distutils-r1_python_prepare_all
+}