summaryrefslogtreecommitdiff
path: root/net-proxy/microsocks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-proxy/microsocks
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-proxy/microsocks')
-rw-r--r--net-proxy/microsocks/Manifest5
-rw-r--r--net-proxy/microsocks/files/microsocks.confd4
-rw-r--r--net-proxy/microsocks/files/microsocks.initd14
-rw-r--r--net-proxy/microsocks/metadata.xml8
-rw-r--r--net-proxy/microsocks/microsocks-1.0.1_p20200805.ebuild32
5 files changed, 63 insertions, 0 deletions
diff --git a/net-proxy/microsocks/Manifest b/net-proxy/microsocks/Manifest
new file mode 100644
index 000000000000..648ba7c1b3ea
--- /dev/null
+++ b/net-proxy/microsocks/Manifest
@@ -0,0 +1,5 @@
+AUX microsocks.confd 120 BLAKE2B 35c1944730ee2aa7fe807008cbe086ae4155bc67398fa3dc91764283084b85a9e8e0d964fffb67e9654beaf351e1df13a6575f6dfffea67bc00e3dfcd7341522 SHA512 c3b3ed42cd140a11f193a98a59df45bb22ef8dd225023a4c575d5a9956cf1a751671e4c3e937b1375dbdb53e94dffa29a451c01099df557aa835c41186c01637
+AUX microsocks.initd 344 BLAKE2B ab79840664690b2573bbbc800dd59d3d6cbc60344d2c81c084347b9d8916412a2e8fe36bf92debe9e628a8f65c54282f57999db5f5f5a032c941ba1d56ad5c91 SHA512 60fbdb6ae0045afb8b38bbf9729513707cb1bad51e130e9462ecfc59367add0ce3320f2942e22bfa0647ab1d8b1fef568f5521a159ffd9a9e0321c20e42d2db4
+DIST microsocks-1.0.1_p20200805.tar.gz 9119 BLAKE2B e998dcb6f109e6bdfd8580ae316e3d61cba0a47b42206bf7482821a06f4fa3b4c56a42fae3948783d2a99bc70f8b60603699a1afba215b45fafe509396c59ec9 SHA512 966df1d654e0eb759f3aca9988dc9f28fa105c3c8586c3e221e3ebdd6f750cb0f1e2d3f544367e5b469203bfe372e9e8451eac8187408bc1618d68dd00236175
+EBUILD microsocks-1.0.1_p20200805.ebuild 706 BLAKE2B 0966c37001a8084459faa2d28e1793fc528a7be9873cae743a981f116e397721c43b41130dcb60f0f10a17ff2da69828785bda65e8ddcab1b7b3615233f52a63 SHA512 d1dbcfb7fe90232ca1874e80be40a919cd0b240ab79f59b798195d0608a70ef3bbdfa3c491ade78ca4825a832719641f623a669f2a2f48a4e26280a6a69fffad
+MISC metadata.xml 249 BLAKE2B 9e4529cdac0a55f14c36fde3fa54e30645a61a73d58e83ce460edf84d729bb3cd4cdc3e52d588690945508bc7d253b1edfb7734ebee94a88b75fee249a043c84 SHA512 ecad16da7f98e9b1cb1882147e6d8b7d541e4839d92fc26f3db1bea69ed633637da9259947b2b78d204a11d0edd3daa84f173613b6dc19110b5406c6fddfa7f0
diff --git a/net-proxy/microsocks/files/microsocks.confd b/net-proxy/microsocks/files/microsocks.confd
new file mode 100644
index 000000000000..1c9387fb09c3
--- /dev/null
+++ b/net-proxy/microsocks/files/microsocks.confd
@@ -0,0 +1,4 @@
+# /etc/conf.d/microsocks - config for microsocks
+#
+# see README.md or --help for possible parameters
+microsocks_args=""
diff --git a/net-proxy/microsocks/files/microsocks.initd b/net-proxy/microsocks/files/microsocks.initd
new file mode 100644
index 000000000000..a520e94920cc
--- /dev/null
+++ b/net-proxy/microsocks/files/microsocks.initd
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="microsocks daemon"
+description="Multithreaded, small, efficient SOCKS5 server"
+pidfile="/run/${RC_SVCNAME}.pid"
+command=/usr/bin/microsocks
+command_args="${microsocks_args}"
+command_background=1
+
+depend() {
+ need net
+}
diff --git a/net-proxy/microsocks/metadata.xml b/net-proxy/microsocks/metadata.xml
new file mode 100644
index 000000000000..cee379b15409
--- /dev/null
+++ b/net-proxy/microsocks/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-proxy/microsocks/microsocks-1.0.1_p20200805.ebuild b/net-proxy/microsocks/microsocks-1.0.1_p20200805.ebuild
new file mode 100644
index 000000000000..ed8fd541226f
--- /dev/null
+++ b/net-proxy/microsocks/microsocks-1.0.1_p20200805.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+COMMIT_HASH="de2d746862e1ec78688500955e15706f173a1151"
+DESCRIPTION="Multithreaded, small, efficient SOCKS5 server"
+HOMEPAGE="https://github.com/rofl0r/microsocks"
+SRC_URI="https://github.com/rofl0r/microsocks/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+ sed -r -e 's:/usr/local:/usr:' -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}