summaryrefslogtreecommitdiff
path: root/net-proxy/hatop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /net-proxy/hatop
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'net-proxy/hatop')
-rw-r--r--net-proxy/hatop/Manifest2
-rw-r--r--net-proxy/hatop/hatop-0.8.1.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/net-proxy/hatop/Manifest b/net-proxy/hatop/Manifest
index e72fb38fffaa..aae1afccc5c1 100644
--- a/net-proxy/hatop/Manifest
+++ b/net-proxy/hatop/Manifest
@@ -1,3 +1,5 @@
DIST hatop-0.8.0.tar.gz 134737 BLAKE2B bc5b1f878dc3ff388c788b6f4a07d9a3076ca3c2c11de15ec6d1ad17d5b2295162568791e4dc9e3edf091a08c80662ceb4d5a6d276e69dd3c96132cb78d007ee SHA512 1776da58a12835434d7b8f59582bad44fb3bf9479f05fedb45f84bc73792b331dda63f989c8b202436801a30600283ec782380e16aa75abf7643ffa5da029718
+DIST hatop-0.8.1.tar.gz 136760 BLAKE2B 3692e9dd307d5f098bd3a66a3a75be5184e17d246dc94b3581d2742c9629d558dc4768baaef1c1e290825e57a651dccc926f22b4ecc98074cc8309fdda4b4b57 SHA512 25026ddd62ef43f02cfb3ef41a815adf232c8a4b3053e925dcea69696c207ffbf22966ce1177ef460071e683f5a4ec8d011d2bb2b0aa06f4a9b3e5932aae93b6
EBUILD hatop-0.8.0.ebuild 665 BLAKE2B 2a317267949c00ee7a0ece49941958a200bfe637049d352cd79fc2a79aee378c9102a756db5200582ba032e7bfb5d95043df336b3ba87ff28cca1b0dd8d3b8e7 SHA512 ecfcf0935a758064db223706f72f88753437c1818c2364a4dc05a70ba593cd186070e6af8884fa7f249268dcddf8289d2f68b34f8e5ca74739d0c451dedb64d0
+EBUILD hatop-0.8.1.ebuild 665 BLAKE2B 74c6b60f0511cf71715c1d3fb6befbb9c6c60e42a746e300b95f99963d566c65dc251ccb2994fa55f9c59f31a3ccaa0c14802478ee17e737b8178baa19a70304 SHA512 e252c91723da1c521da86c59af759da1602db454639f7bdcc733a9b8a804b2fda3b77104ca2db86ceeca36274202d14b3f7d2e3f029fddd01eeee85788498d9f
MISC metadata.xml 250 BLAKE2B 127d3b63d96953a7263c1ecb0f0cd905cbba9006349ae20351476072eb08aa6e5d0da402e3a90fea218e2e05971096bbfd13d2bb6f57221d8772885075dc6523 SHA512 a8423fb0d09057a311f01b4fe8bc03d0535b701a96846a7617e9ea61d7aa3ccd7e8de31451488a7db435e8f8178a5dd70e5511080eccee8880d6959d9de4c0d5
diff --git a/net-proxy/hatop/hatop-0.8.1.ebuild b/net-proxy/hatop/hatop-0.8.1.ebuild
new file mode 100644
index 000000000000..9b40160d20ed
--- /dev/null
+++ b/net-proxy/hatop/hatop-0.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="ncurses"
+
+inherit python-r1
+
+DESCRIPTION="Ncurses client and real-time monitoring and displaying of HAProxy status"
+HOMEPAGE="https://github.com/jhunt/hatop"
+SRC_URI="https://github.com/jhunt/hatop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ python_foreach_impl python_doscript bin/hatop
+
+ doman man/hatop.1
+
+ dodoc CHANGES.rst KEYBINDS README.rst
+}