summaryrefslogtreecommitdiff
path: root/net-proxy/haproxy/haproxy-2.1.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-proxy/haproxy/haproxy-2.1.9999.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-proxy/haproxy/haproxy-2.1.9999.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-2.1.9999.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-proxy/haproxy/haproxy-2.1.9999.ebuild b/net-proxy/haproxy/haproxy-2.1.9999.ebuild
index 06e10c936692..7e2cb38725c6 100644
--- a/net-proxy/haproxy/haproxy-2.1.9999.ebuild
+++ b/net-proxy/haproxy/haproxy-2.1.9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit user toolchain-funcs flag-o-matic systemd linux-info $SCM
+inherit toolchain-funcs flag-o-matic systemd linux-info $SCM
MY_P="${PN}-${PV/_beta/-dev}"
@@ -45,7 +45,9 @@ DEPEND="
zlib? ( sys-libs/zlib )
lua? ( dev-lang/lua:5.3 )
device-atlas? ( dev-libs/device-atlas-api-c )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ acct-group/haproxy
+ acct-user/haproxy"
S="${WORKDIR}/${MY_P}"
@@ -63,9 +65,6 @@ haproxy_use() {
}
pkg_setup() {
- enewgroup haproxy
- enewuser haproxy -1 -1 -1 haproxy
-
if use net_ns; then
CONFIG_CHECK="~NET_NS"
linux-info_pkg_setup