summaryrefslogtreecommitdiff
path: root/net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.5.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.5.1.ebuild')
-rw-r--r--net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.5.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.5.1.ebuild b/net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.5.1.ebuild
new file mode 100644
index 000000000000..cc101b866c2f
--- /dev/null
+++ b/net-proxy/haproxy-dataplaneapi/haproxy-dataplaneapi-2.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="haproxy dataplane api / sidecar"
+HOMEPAGE="https://github.com/haproxytech/dataplaneapi https://www.haproxy.com/documentation/dataplaneapi/latest/"
+
+SRC_URI="https://github.com/haproxytech/dataplaneapi/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ http://gentooexperimental.org/~patrick/haproxy-dataplaneapi-2.5.1-deps.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/dataplaneapi-${PV}"
+
+src_compile() {
+ GOBIN="${S}/bin" emake build
+}
+
+src_install() {
+ dobin build/dataplaneapi
+ dodoc README.md
+}