summaryrefslogtreecommitdiff
path: root/net-print/hplip-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-03 04:04:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-03 04:04:58 +0100
commitc6872c361190d4f1a559d23458f6cdffb154b0b0 (patch)
tree98d2caa2e0d46d9968c7cc155946e785f96e6db3 /net-print/hplip-plugin
parenta55e5c074db9bb024358a8f0bd2c5e992b7cf6f6 (diff)
gentoo auto-resync : 03:07:2023 - 04:04:58
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest2
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.23.5.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index d1e9d33db336..24b46b74da56 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,5 @@
DIST hplip-3.23.3-plugin.run 11491593 BLAKE2B 94ba1cf92661f738f19d0c1c42b513569dad7815aeb9dad2d791f68f8ee893ca380fab2c7ff2b1fb9527851d288ec2993875952d889dac0e963b6f19c201d484 SHA512 048c545869f9679daa581b63236d57fbc362c39a4f3f6c6afe66552ac1b2def1563ec5b19d3feda44dbd564e2b0f2794833b24752a6139dc77d848146e283074
+DIST hplip-3.23.5-plugin.run 11491464 BLAKE2B 78f2f5cb60dc273d9d5c26909b277d36379bb345f12b2c4ddb2ba0542cd090872452f055b02d713f84b753f2418ee5a07a9a6852c256078747b30a15d7a0f352 SHA512 73389d295c21bc2c49b3aaa130f04784890eb72b3ca02fe1967b48ef1153205bd625c8efee103d96e1abbc7a4550f028153e94351f9437683d2579d910807dd4
EBUILD hplip-plugin-3.23.3.ebuild 1483 BLAKE2B c75f0e9c64e2f71916ec9b8a67b41faefffee00cce74e3ab2df526b271b90b26cd20ccbd0549cd43e0362f33650158b17334a063260a65734cf673ef8e9606d4 SHA512 166432f69b79f75c142db0febcb91cdccb9ecea2a98bf1a9afd6f10cc5ee52b357fd21772ededa54dcb6842400b34368659cfca51af33578c4cc292c58a5099c
+EBUILD hplip-plugin-3.23.5.ebuild 1487 BLAKE2B 3c55959b558140453513c729340c7e1679616233179a73db268797bfdf9d8714d61d4d5acd66b09243d701f0ebfe35e52565c2dcb17c5aeda3b8c4e21289b3c9 SHA512 c3d5ad92e8a6085d37b50a59ee4d61e1b9603129401a7d8aaa94dc24a6b7e46a7b3b576b76d36506afb2c1928d0ce4b7215194f3e981abe9a0a5d2b77af93431
MISC metadata.xml 523 BLAKE2B 396a3e3f19f1929ac628fd3301f7de077e34d80b88f0f65dd4035a55b8ff16be6a89dc94b47085dafc7a8a2def19353aa52996a12e51e94154a61ba1329f8c91 SHA512 9d5abebbd6fdac76142c70aa911c4ac55eb5388fd39e010d72e8e6253f51a7924eda2a675cd8ce3475fea76b307805644cf8f7140b265e66b4fcd65a8546fd96
diff --git a/net-print/hplip-plugin/hplip-plugin-3.23.5.ebuild b/net-print/hplip-plugin/hplip-plugin-3.23.5.ebuild
new file mode 100644
index 000000000000..4bf67bc6bda1
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.23.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}