summaryrefslogtreecommitdiff
path: root/net-print/hplip-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-22 01:05:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-22 01:05:27 +0000
commitb7819d03d7312d3d8d12b49738aa417f35f6e18a (patch)
treeddda281c46717f76e2c0d0ea4ed00da4bd58d9b5 /net-print/hplip-plugin
parent77b9f0d5906f0bd9ddf010abe155218c6629738a (diff)
gentoo auto-resync : 22:11:2022 - 01:05:27
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest2
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.22.10.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 994fb28bfbaf..fcf4aa5d458a 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,5 @@
+DIST hplip-3.22.10-plugin.run 11494258 BLAKE2B c9cca80349af4f04f1b1d055083fea451d079a08179fe29fb8ca056c76a36847a58cdc526080d16620a7ab7b8650ccc46f15b3a63447964a6f6006e54b316905 SHA512 dfedc343898fb7b9e951de9a09578627b208f7d0652666eb05d5926ad3ec220bd049d6bee1fb211c72f2e484925e48a665c3133aeeca9d19032fd95e0c3711fa
DIST hplip-3.22.6-plugin.run 11493966 BLAKE2B 9346625c665c25c5c065462269fba4764ef6728a5a351fc0ca81d5fbd3af41185d18cbee88bc9ae0c40909ed1dd412c5f53486676daf0459b79a612c7d65c257 SHA512 6eafe71f88a012bc95ecdf5bf70756e08074208964183b057f299167030b9d228c934c08955c400333b88b46d7d55ed25eb0792a8ed24b4df97a61dddca64585
+EBUILD hplip-plugin-3.22.10.ebuild 1487 BLAKE2B e80cf0d84b6a8bd542f60eb43a7ba99908913a25d9158c10d3c25e829d47bb74edbb4342bcd57891cfa6293c9fd8c95c186fab6e9afa5cec1b8a6d8bff32608f SHA512 3666cfece271f4e9f04f1b7bb5f34580f42867c070b08c3282cbe80df34a2885640e6b150afc977c3c3498e3b083c4ed96a5995ce46f66eb3d39493196c9e4fd
EBUILD hplip-plugin-3.22.6.ebuild 1484 BLAKE2B 00d10feb206b7c70c6523e5c8757a4a1d4846d20be7d1b34e0d4ceda452d686404abee5a01d76b6cf9ba5510ecdb79e87807a4635c19cdce79ab9a3999e5faec SHA512 e6947d194de5aee27f8253d104ddc0d1ba82d83f54fee6106b4f5937c2d05e26fa78306dee8cfd208c84add673f953bd73462c8e64413ffc32979456eeba9260
MISC metadata.xml 523 BLAKE2B 396a3e3f19f1929ac628fd3301f7de077e34d80b88f0f65dd4035a55b8ff16be6a89dc94b47085dafc7a8a2def19353aa52996a12e51e94154a61ba1329f8c91 SHA512 9d5abebbd6fdac76142c70aa911c4ac55eb5388fd39e010d72e8e6253f51a7924eda2a675cd8ce3475fea76b307805644cf8f7140b265e66b4fcd65a8546fd96
diff --git a/net-print/hplip-plugin/hplip-plugin-3.22.10.ebuild b/net-print/hplip-plugin/hplip-plugin-3.22.10.ebuild
new file mode 100644
index 000000000000..54c789992915
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.22.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}