summaryrefslogtreecommitdiff
path: root/net-print/hplip-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /net-print/hplip-plugin
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest2
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.19.11.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 6cae7d0603e4..cf19dcec9966 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,5 +1,7 @@
DIST hplip-3.18.12-plugin.run 10486821 BLAKE2B e48940b1b5fe94dc216383b63bee7807bce9ad265b7c454c201c0ed22ec1964e6c5adf653c3c230789c042cffaaf50bd604bae6f66f407a85f98248934307158 SHA512 82b90aa8245f787e088a1bebfa7892a7f2b97fd04b3702c46eed27306640e562aeec63b4b5b45c24943abe4672f2627d1821bdcdf58a5c1ac4e1d06c7270535f
+DIST hplip-3.19.11-plugin.run 11517119 BLAKE2B d7eefde4e579abbb019cfbb5bf7541360884b0d18240c87c0b532981ad3542a60dae139a623db0eaee3057d6fb5e805287ad5bddb2ec87df5b85ffd604f748f4 SHA512 9ef568aa297eb58370e7f01e54d83c53fbfb02494a0f4cfa3b9f92fd11bfae7b9f54d60516d5cf0436a882864505aab68f70b462b820e918a6ad4104987c9295
DIST hplip-3.19.6-plugin.run 11517158 BLAKE2B c44707e29b104b45c110729c70ebeba1f392ad753eb98d8677657f735e547cdecfab357b348a30545274b51c18249ddb9102df49aa73d726a8e9145a302a8a0c SHA512 3636d655ba289331572f0762a5de2e0bf2f3108ac3f7ca9cb8bbec126942be954fe9c07c882bd8272e30ac46d67231d86a3c4249a6fe31e2d3e8d5e568bbbd8b
EBUILD hplip-plugin-3.18.12.ebuild 1635 BLAKE2B 421610d7a88268aced86e4b30a4e6798fcdb07fd1b321b3caf65c1e444d9034b461e606f42fe75879a6f19cddc7b5d6264a02febb24e11d126a073b50c517b9c SHA512 3ec01211d1ce65e56e3b2a904390a7ead68a4fec8681b26ed36d2dae7daf7c78d79fec06684b1fccf675290bfed8214693f429b58c2a395ce682016750337865
+EBUILD hplip-plugin-3.19.11.ebuild 1582 BLAKE2B c154a00fae8a57e1b210714728fac79256f14fc8e850936caa1fd6273199f60087cb8cbaf96ba3d0afaf0109638031f9de010812f585676e6af8cca4e2d6cad6 SHA512 eca251a0e72c19a4bf4809a84de741b9704ee20fb82bf669eaeb4f4e9125ead78b3635002120e96c4fd1fbda2060bc8672a8d81caea048eb240ee7305bea7b51
EBUILD hplip-plugin-3.19.6.ebuild 1582 BLAKE2B c154a00fae8a57e1b210714728fac79256f14fc8e850936caa1fd6273199f60087cb8cbaf96ba3d0afaf0109638031f9de010812f585676e6af8cca4e2d6cad6 SHA512 eca251a0e72c19a4bf4809a84de741b9704ee20fb82bf669eaeb4f4e9125ead78b3635002120e96c4fd1fbda2060bc8672a8d81caea048eb240ee7305bea7b51
MISC metadata.xml 334 BLAKE2B 8f1a0784c57af6204db98f443bdb09df2a6432674d711a5ecf577c20e29f04a030549ea19c6e04f51cd9a36e60a6da94bebafbfcc10d52da87109e59c32d42ee SHA512 105a5442ba05b94b2886f9075bd89268d4f2e0567ad69a637a1bd7d7d0eafdc280dfdb198aab5d72525300a9be0d4ad78f6bfe6398c896cc9de0f591651d102c
diff --git a/net-print/hplip-plugin/hplip-plugin-3.19.11.ebuild b/net-print/hplip-plugin/hplip-plugin-3.19.11.ebuild
new file mode 100644
index 000000000000..b497f4a93fa1
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.19.11.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/libusb:0
+ virtual/udev
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PRESTRIPPED="
+ /usr/share/hplip/fax/plugins/fax_marvell.so
+ /usr/share/hplip/prnt/plugins/hbpl1.so
+ /usr/share/hplip/prnt/plugins/lj.so
+ /usr/share/hplip/scan/plugins/bb_escl.so
+ /usr/share/hplip/scan/plugins/bb_marvell.so
+ /usr/share/hplip/scan/plugins/bb_soapht.so
+ /usr/share/hplip/scan/plugins/bb_soap.so
+"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_install() {
+ local hplip_arch
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ fax_*) plugin_type=fax ;;
+ bb_*) plugin_type=scan ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}