summaryrefslogtreecommitdiff
path: root/net-print/hplip-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 17:18:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 17:18:10 +0000
commit627302fc2f41a621644260ffa3f50e06ea5edd60 (patch)
tree0559b6826aa029213d2980eff2e007fa11d715ff /net-print/hplip-plugin
parent92e45d8c110d3b9403a141d225037f2c8ed90450 (diff)
gentoo auto-resync : 10:12:2023 - 17:18:10
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest2
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.23.12.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 28fec33ea4b8..085d761307bf 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,5 @@
+DIST hplip-3.23.12-plugin.run 11491524 BLAKE2B 9b87522a78588d65815992a170451888b4c6ac83809498fae01cfa4d2c333657a7cf49f2358e12ebfd0ae0f4169e29729e9ef8ba6716f74de0a83b11552275e3 SHA512 933c27040443584e0cfda71b50b8a251ebd34fdf4a2c90f40e36d1c155b3ae87c1474835356f685de2997469b4b7a3f000e216fd427118eea2542fa142783ab9
DIST hplip-3.23.8-plugin.run 11491257 BLAKE2B 1e87b741ebb28605c18954033e5b34ce2456671786e5472665e307253121635c23ecb920f974042ddbf8ebe76882d810f1fce2d39a46fadf774048f9a5673b33 SHA512 ba27bb609d2c17972bc7506ca6e9ef8c389c764c8276d0b1ddd711254f9bdb5c354ebe05026e392bfc261648fc57ccf199f60403c0bfbc3aceb78fcf890a39db
+EBUILD hplip-plugin-3.23.12.ebuild 1487 BLAKE2B 3c55959b558140453513c729340c7e1679616233179a73db268797bfdf9d8714d61d4d5acd66b09243d701f0ebfe35e52565c2dcb17c5aeda3b8c4e21289b3c9 SHA512 c3d5ad92e8a6085d37b50a59ee4d61e1b9603129401a7d8aaa94dc24a6b7e46a7b3b576b76d36506afb2c1928d0ce4b7215194f3e981abe9a0a5d2b77af93431
EBUILD hplip-plugin-3.23.8.ebuild 1483 BLAKE2B c75f0e9c64e2f71916ec9b8a67b41faefffee00cce74e3ab2df526b271b90b26cd20ccbd0549cd43e0362f33650158b17334a063260a65734cf673ef8e9606d4 SHA512 166432f69b79f75c142db0febcb91cdccb9ecea2a98bf1a9afd6f10cc5ee52b357fd21772ededa54dcb6842400b34368659cfca51af33578c4cc292c58a5099c
MISC metadata.xml 523 BLAKE2B 396a3e3f19f1929ac628fd3301f7de077e34d80b88f0f65dd4035a55b8ff16be6a89dc94b47085dafc7a8a2def19353aa52996a12e51e94154a61ba1329f8c91 SHA512 9d5abebbd6fdac76142c70aa911c4ac55eb5388fd39e010d72e8e6253f51a7924eda2a675cd8ce3475fea76b307805644cf8f7140b265e66b4fcd65a8546fd96
diff --git a/net-print/hplip-plugin/hplip-plugin-3.23.12.ebuild b/net-print/hplip-plugin/hplip-plugin-3.23.12.ebuild
new file mode 100644
index 000000000000..4bf67bc6bda1
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.23.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}