summaryrefslogtreecommitdiff
path: root/net-print/hplip-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-print/hplip-plugin
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-print/hplip-plugin')
-rw-r--r--net-print/hplip-plugin/Manifest2
-rw-r--r--net-print/hplip-plugin/hplip-plugin-3.22.4.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 6485e576ced0..06666c51ee1c 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,3 +1,5 @@
DIST hplip-3.22.2-plugin.run 11487296 BLAKE2B 2c953e85b3ef299066aaf158121f4a3db68b00f2e2df3cb35acc78a54a466e8a3e204592fbfa2128acb87c0f9b258178cd29faf4e93600ee4b10fe81b93f213b SHA512 5efa533863bec3e7e5fc354411216e6e4232c2bbc15a062ff829296e1357c523333df8221a341b10c940022708299a33449020e633a9873205b568959327cb24
+DIST hplip-3.22.4-plugin.run 11487215 BLAKE2B dc9b0977c35bff29c81f3854e7104301c3bd96cf77833a056a09dd2b2465e8f47c53c941ff4d1235f62eae9a3af93fe95129111d7abf5e82032959de1167920e SHA512 be53ad8d2f910d772535775037b912f332122a6aa141fa2f92415dd9a259efca34011939e648fc7a46e8123ee409396b28236947e37539153c55f80c6d7f8cd1
EBUILD hplip-plugin-3.22.2.ebuild 1484 BLAKE2B 00d10feb206b7c70c6523e5c8757a4a1d4846d20be7d1b34e0d4ceda452d686404abee5a01d76b6cf9ba5510ecdb79e87807a4635c19cdce79ab9a3999e5faec SHA512 e6947d194de5aee27f8253d104ddc0d1ba82d83f54fee6106b4f5937c2d05e26fa78306dee8cfd208c84add673f953bd73462c8e64413ffc32979456eeba9260
+EBUILD hplip-plugin-3.22.4.ebuild 1487 BLAKE2B e80cf0d84b6a8bd542f60eb43a7ba99908913a25d9158c10d3c25e829d47bb74edbb4342bcd57891cfa6293c9fd8c95c186fab6e9afa5cec1b8a6d8bff32608f SHA512 3666cfece271f4e9f04f1b7bb5f34580f42867c070b08c3282cbe80df34a2885640e6b150afc977c3c3498e3b083c4ed96a5995ce46f66eb3d39493196c9e4fd
MISC metadata.xml 523 BLAKE2B 396a3e3f19f1929ac628fd3301f7de077e34d80b88f0f65dd4035a55b8ff16be6a89dc94b47085dafc7a8a2def19353aa52996a12e51e94154a61ba1329f8c91 SHA512 9d5abebbd6fdac76142c70aa911c4ac55eb5388fd39e010d72e8e6253f51a7924eda2a675cd8ce3475fea76b307805644cf8f7140b265e66b4fcd65a8546fd96
diff --git a/net-print/hplip-plugin/hplip-plugin-3.22.4.ebuild b/net-print/hplip-plugin/hplip-plugin-3.22.4.ebuild
new file mode 100644
index 000000000000..54c789992915
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.22.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+S="${WORKDIR}"
+
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="orblite"
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+RDEPEND="
+ ~net-print/hplip-${PV}
+ virtual/udev
+ orblite? (
+ media-gfx/sane-backends
+ >=sys-libs/glibc-2.26
+ virtual/libusb:0
+ )
+"
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+src_install() {
+ local hplip_arch plugin
+ case "${ARCH}" in
+ amd64) hplip_arch="x86_64" ;;
+ arm) hplip_arch="arm32" ;;
+ arm64) hplip_arch="arm64" ;;
+ x86) hplip_arch="x86_32" ;;
+ *) die "Unsupported architecture." ;;
+ esac
+
+ insinto "${HPLIP_HOME}"/data/firmware
+ doins *.fw.gz
+
+ for plugin in *-${hplip_arch}.so; do
+ local plugin_type=prnt
+ case "${plugin}" in
+ bb_orblite-*)
+ use orblite || continue
+ plugin_type=scan ;;
+ bb_*)
+ plugin_type=scan ;;
+ fax_*)
+ plugin_type=fax ;;
+ esac
+
+ exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+ newexe ${plugin} ${plugin/-${hplip_arch}}
+ done
+
+ insinto /var/lib/hp
+ newins - hplip.state <<-_EOF_
+ [plugin]
+ installed = 1
+ eula = 1
+ version = ${PV}
+ _EOF_
+}