summaryrefslogtreecommitdiff
path: root/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 16:30:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 16:30:06 +0100
commit788bcc2dc1910a097d019f25e3e70dc7b4fdc903 (patch)
tree4c99604559949fa13bc67f0a6127d848136e5b5f /net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.0.ebuild
parentf9a53aec073578673710687755db617717dd87d3 (diff)
gentoo auto-resync : 11:07:2023 - 16:30:06
Diffstat (limited to 'net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.0.ebuild')
-rw-r--r--net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.0.ebuild b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.0.ebuild
new file mode 100644
index 000000000000..9383dcbb9383
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Epson Inkjet Printer Driver (ESC/P-R)"
+HOMEPAGE="https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/14/61/09/b271f0e3ed6b3bc0ea5b5809d16d48ef83e9ab71/${P}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/1.6.5-warnings.patch"
+ "${FILESDIR}/${PN}-1.7.7-fnocommon.patch"
+)
+
+src_configure() {
+ econf --disable-shared
+
+ # Makefile calls ls to generate a file list which is included in Makefile.am
+ # Set the collation to C to avoid automake being called automatically
+ unset LC_ALL
+ export LC_COLLATE=C
+}
+
+src_install() {
+ emake -C ppd DESTDIR="${D}" install
+ emake -C src DESTDIR="${D}" install
+ einstalldocs
+}