summaryrefslogtreecommitdiff
path: root/net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild')
-rw-r--r--net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild b/net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild
new file mode 100644
index 000000000000..7cb5d901f866
--- /dev/null
+++ b/net-print/cups-pk-helper/cups-pk-helper-0.2.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="PolicyKit helper to configure cups with fine-grained privileges"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/cups-pk-helper"
+SRC_URI="https://www.freedesktop.org/software/${PN}/releases/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND="
+ >=dev-libs/glib-2.30.0:2
+ net-print/cups
+ >=sys-auth/polkit-0.97
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.40.6
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_prepare() {
+ DOCS="AUTHORS HACKING NEWS README"
+
+ # Regenerate dbus-codegen files to fix build with glib-2.30.x; bug #410773
+ rm -v src/cph-iface-mechanism.{c,h} || die
+
+ gnome2_src_prepare
+}