summaryrefslogtreecommitdiff
path: root/net-print/cups-filters
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-28 04:02:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-28 04:02:51 +0000
commit87f37a073fb5c2e1f6ebc780e60cdbdd2c583860 (patch)
tree9872190e1841d9f126084652bf3b6b2687c6f1bb /net-print/cups-filters
parenta87296ad796f00f3bba27339f6efe11b9a384e23 (diff)
gentoo auto-resync : 28:02:2023 - 04:02:51
Diffstat (limited to 'net-print/cups-filters')
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.28.17-r1.ebuild145
2 files changed, 146 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index 2402d3b1aede..9f562e95dc72 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -4,5 +4,6 @@ DIST cups-filters-1.28.16.tar.xz 1512496 BLAKE2B a75a9e09688670332a9fd9a8e4d9004
DIST cups-filters-1.28.17.tar.xz 1516052 BLAKE2B 87258391901d55d9e59b06d54603d014e54d224a373529bd70fcd38cded9dc96c88ca73bcea63d7633c065caea3f9e3274cd450aec5f1bd90130d9a88c0d3421 SHA512 320544a48206165581adafb28dbef58f39c66bebd3641be3d180a692605349d9e6af6d464044db9f7bda17a67f4a079370d8cc880cd7873d684b2209882deb35
EBUILD cups-filters-1.28.15-r1.ebuild 3287 BLAKE2B bcc2f0b85f735c1a7c10c1e32a9bd3c6fb975c22e00a33bb082188f9136cb77319d461dc40706b61b601376469b4a16be7826f05fe86f6092330fe8c5bf26f2b SHA512 d0d2117ea64feacc1eb3e6683099f8f79dbe47b060de4dce9e31f784db6b9668d1d993c641747c8ce52d03fcf757f7999e1344aeb636ca725a1e342436c008e8
EBUILD cups-filters-1.28.16-r3.ebuild 3572 BLAKE2B 79f2d5c3416a3e7057babe51899bf91590cda9e860593d9c6cc0b4d3ee60a01451a8198e501df620de9a25c5d6b523a4ac6013905700dbfe55c0ac5c0e7bad39 SHA512 fd03ca153effb3abaa814a9fcefc0d1f53fb9d0f8bb829076bd88452a35b9d968c4c31f9519e4004a3d38d6c8c204d3294ff7aadf10eded3f9932f5ef194aef9
+EBUILD cups-filters-1.28.17-r1.ebuild 3576 BLAKE2B 3982e0a8a5c8eeec28b32d73e6838dfdbcf1065e118c0639e952d24f2e03860f5931c32041086b716497b269a30fd4b3075b536250868f05a817fe893888899c SHA512 d5808dd65a71abf095fc0dd3f5b3d3eb2a2bf1013527af97bedbcdba81b95591826db1d9d3350bf8c9cbf05abba460a45aee8f3a25d7f6402fad1615741089d1
EBUILD cups-filters-1.28.17.ebuild 3665 BLAKE2B a5eef3c747cca21d793727bb73ba285923959ea8ba92285814b692de926f0c4e7a65f2c08f3246db3a14ba62faaaf67e96a7a71852de13c2949038e50bd2802c SHA512 02abd7eab72b574ae54f3dcc6180973b812f9558f0510b2418b55dee102d78e65bf1408d2c042253ca49c2d2f5ae872632ea3b358737f7ec3aba546e764ad725
MISC metadata.xml 513 BLAKE2B b265a1645fe0da46a309086d9495564020ea15b7546237dc040589cba2e5d79540860301f8f72484081b726066414ad0414963b7c7c2ce3f08af898502c32521 SHA512 b9234992f05d59bffafb31f3d035e554389f250d8f3b951bb507e300f7cd3a6806406df60b1cae038ab330b3513934ec1250dcf0c9bfdba1bb033e6545727597
diff --git a/net-print/cups-filters/cups-filters-1.28.17-r1.ebuild b/net-print/cups-filters/cups-filters-1.28.17-r1.ebuild
new file mode 100644
index 000000000000..2e2bbd3cef13
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.28.17-r1.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GENTOO_DEPEND_ON_PERL=no
+inherit perl-module systemd flag-o-matic
+
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+SRC_URI="
+ https://github.com/OpenPrinting/cups-filters/releases/download/${PV}/${P}.tar.xz
+ https://www.openprinting.org/download/${PN}/${P}.tar.xz
+"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus exif +foomatic jpeg ldap pclm pdf perl png +postscript test tiff zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-text/poppler-0.32[cxx,jpeg?,lcms,tiff?,utils]
+ >=app-text/qpdf-8.3.0:=
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ exif? ( media-libs/libexif )
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ ldap? ( net-nds/openldap:= )
+ pdf? ( app-text/mupdf:= )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:= )
+ postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+ tiff? ( media-libs/tiff:= )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+ test? ( media-fonts/dejavu )
+"
+
+src_configure() {
+ # Bug #898156
+ append-cxxflags -std=c++17
+
+ local myeconfargs=(
+ --enable-imagefilters
+ --localstatedir="${EPREFIX}"/var
+ --with-browseremoteprotocols=DNSSD,CUPS
+ --with-cups-rundir="${EPREFIX}"/run/cups
+ --with-fontdir="fonts/conf.avail"
+ --with-pdftops=pdftops
+ --with-rcdir=no
+ --without-php
+
+ $(use_enable exif)
+ $(use_enable dbus)
+ $(use_enable foomatic)
+ $(use_enable ldap)
+ $(use_enable pclm)
+ $(use_enable pdf mutool)
+ $(use_enable postscript ghostscript)
+ $(use_enable zeroconf avahi)
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with tiff)
+ )
+
+ econf "${myeconfargs[@]}"
+
+ if use perl; then
+ pushd "${S}"/scripting/perl > /dev/null || die
+ perl-module_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}"/scripting/perl > /dev/null || die
+ perl-module_src_compile
+ popd > /dev/null || die
+ fi
+}
+
+src_test() {
+ # Avoid perl-module_src_test
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null || die
+ perl-module_src_test
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}"/scripting/perl > /dev/null || die
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null || die
+ fi
+
+ if use postscript; then
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym gstopxl /usr/libexec/cups/filter/pstopxl
+ fi
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ cp "${FILESDIR}"/cups-browsed.init.d-r2 "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}"/utils/cups-browsed.service
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely"
+ ewarn "necessary. net-print/foomatic-filters as a replacement is deprecated and unmaintained."
+ fi
+}