summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-22 01:20:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-22 01:20:40 +0100
commitcb6b2150348c9dc57c68bcba47bcdb6f20e8e508 (patch)
tree4d89a8eab47a7fbc14b209c7c252724a72c68f8a /net-p2p
parentc0bcbed1a8a833beeae3ab7541dc9f460ab7cfce (diff)
gentoo auto-resync : 22:06:2023 - 01:20:39
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/Manifest.gzbin6759 -> 6756 bytes
-rw-r--r--net-p2p/qbittorrent/Manifest2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.5.4.ebuild104
3 files changed, 106 insertions, 0 deletions
diff --git a/net-p2p/Manifest.gz b/net-p2p/Manifest.gz
index ea9bf0c4a4bb..c5fc3378f103 100644
--- a/net-p2p/Manifest.gz
+++ b/net-p2p/Manifest.gz
Binary files differ
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 9162bb108662..38de34d7c3a5 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,4 +1,6 @@
DIST qbittorrent-4.5.2.tar.gz 8890525 BLAKE2B 48585b703ce6edf862ea3c8cfad6cab2edcb65a138c6e8d232322b4f4fd682c87447ff11d29c04c26b5623e730ab9a1ce0496456b3ba6122f97913bd92b86790 SHA512 e900a1c5f0f70163463557aec3de0d31394fac56cfed91ea53ee5cf852cce4b2998bf79be60fc547c1c34a1658378f3ed9dbfb30aae5a772b85d819c7e7ce458
+DIST qbittorrent-4.5.4.tar.gz 8791236 BLAKE2B 70b3194d6c4819655998406e0a13d22f3a5068e724048010daebd83d8b8db9e17daee943ca8dabaacd92a0fbc5249257de6d175b35287c748dc2d15395bd71fc SHA512 2e7988922137c9fade99e90236cc0c5b8b30f09021472f8ffc9048a7a2d989925eed7bfab4d79c93ca7d0f21acfde2e7feee5e6c43b557bf2c6f472fd52fbcea
EBUILD qbittorrent-4.5.2-r1.ebuild 2193 BLAKE2B a1cca9de23750e3a0b3a724f7ba21b0b398a97202fc0a41fd8efb10039e5e4a67bf97c97d4662855672c85ec398718699c2befd953339dac42259a49142ba2a8 SHA512 2c06ef6f6c768ed51f769a367fee57c82948f7d09d578c0bd1408e4ac7a525b4ca003b0124d77b666014b483792084262bb7be5be905a4ef09285b3d59bdebae
+EBUILD qbittorrent-4.5.4.ebuild 2195 BLAKE2B 8256d77dbf0ef6abe2042b13030aaa802ab2ff8765258a8a985daa3d7dfa6099e34ba3526463799a19c07584c9c6bfc90f7ce26705d0c47d2697591c92629e2d SHA512 e7bba9623402d84053bc583ad5e7fbf60fc3e2c435fd312888b8e2e29f7cc4abe2bc022c213d031aa553de19d498cd47105e047759a4be27f7d7906f539136e2
EBUILD qbittorrent-9999.ebuild 2654 BLAKE2B 51a384295b444603120b7e5e18b9b37f0faad05483be7bf43614ac984cd21b6cc5a965abde0cf379dd8211e0fede18bb1daf6542dd9341185afa3e961d417fdd SHA512 b102f0563325040fcab1ef32d9090605c5a30f27833458164fc5afb4d9dc8ef1ea2f94fb49c3e7ea640085bf289b79ae6ac34e238038f8d86646b80790165725
MISC metadata.xml 458 BLAKE2B 8c13d95038dafa12073f44243d8881ec80deaf0f4802da0590b944a4eb99731e6ac8064b0c24a1ef5e7228409ecb5c37031efe6f14bd949170cbc25efd06fb5b SHA512 550b920dfb04cc2b18d1c993af8fe989fd4b7e58a97dd619f45b08eb051b9ceb7f22f0defe9c2bda40bea3e626c9f32b47903474f6216f8ebdcdf40f44b9fe3d
diff --git a/net-p2p/qbittorrent/qbittorrent-4.5.4.ebuild b/net-p2p/qbittorrent/qbittorrent-4.5.4.ebuild
new file mode 100644
index 000000000000..3a7a883a40a5
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.5.4.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake multibuild systemd xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/qbittorrent/qBittorrent.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qbittorrent/qBittorrent/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}"/qBittorrent-release-${PV}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus +gui webui"
+REQUIRED_USE="dbus? ( gui )
+ || ( gui webui )"
+
+RDEPEND="
+ >=dev-libs/openssl-1.1.1:=
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+ dev-qt/qtxml:5
+ <net-libs/libtorrent-rasterbar-2:=
+ >=sys-libs/zlib-1.2.11
+ dbus? ( dev-qt/qtdbus:5 )
+ gui? (
+ dev-libs/geoip
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md )
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ multibuild_src_configure() {
+ local mycmakeargs=(
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+
+ # Not yet in ::gentoo
+ -DQT6=OFF
+
+ -DWEBUI=$(usex webui)
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == gui ]]; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=(
+ -DGUI=ON
+ -DDBUS=$(usex dbus)
+ -DSYSTEMD=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DDBUS=OFF
+ # The systemd service calls qbittorrent-nox, which is only
+ # installed when GUI=OFF.
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR="$(systemd_get_systemunitdir)"
+ )
+ fi
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant multibuild_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+ einstalldocs
+}