summaryrefslogtreecommitdiff
path: root/net-p2p/tremc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-p2p/tremc
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-p2p/tremc')
-rw-r--r--net-p2p/tremc/Manifest4
-rw-r--r--net-p2p/tremc/files/0.9.1-fix-startup-crash.patch62
-rw-r--r--net-p2p/tremc/metadata.xml15
-rw-r--r--net-p2p/tremc/tremc-0.9.1.ebuild41
4 files changed, 122 insertions, 0 deletions
diff --git a/net-p2p/tremc/Manifest b/net-p2p/tremc/Manifest
new file mode 100644
index 000000000000..44c8c35cfcca
--- /dev/null
+++ b/net-p2p/tremc/Manifest
@@ -0,0 +1,4 @@
+AUX 0.9.1-fix-startup-crash.patch 2298 BLAKE2B 0cc6ecfb473d93a6bda34a3d8ebcc9a66d176280bad2d6f356077a2f026540fdcaf5d130475fb687c8292d0402ea6f264a7b67d6a9abd8f9f4356802c0c746b6 SHA512 90d4eebf3913a58bbf8c4e8175c486d1819d6804598320df9cd58a04b6c6c88e06640ca8affc495e6f9c6ceed30b2290982ba774013fbc7f07011f2948936fee
+DIST tremc-0.9.1.tar.gz 315482 BLAKE2B c4e94ef13cc9d716cdbcbff061b1956d17c6babe765e192d675d08ad5d76a22cf171a4fb3f5f2952b971f59a16a2768ccd360d10df5b0f3325fd63ff9716f209 SHA512 ed16080c6544ce9019e6a0c4d660310992cae0f139a2a78e9eaa51841e293cefb22160a105794b5f03a4bfd47a2c50402879f2a17302a96265a9c9acb3174c39
+EBUILD tremc-0.9.1.ebuild 1031 BLAKE2B ec315485a068309eddaa5854bbf83ce5c781d11a30712345be4a1a895ff956ec74b2814c57493f968f30a289388784cb1e7244d232366bd2b0c0432ac213ba46 SHA512 e508957f347a3b59244d7228e6b794bdc79c54b76d3b1ac2966e04a469161dd93d54d83c3e2a861a5fb6019fda1a5bffcb896bc44bf7d23fc1d2c35927f996a0
+MISC metadata.xml 446 BLAKE2B d820391ccf71031227aae66b4cc0b68ec9995d28b1844a12ef42acddb8235f001ad30017943dad6559a39ef9ad9501282dc434e85036e6fa1f531becea3d58b6 SHA512 e32327f3b62e65ced93ecc9433cb3ec6972b93a5344fd21f9d31ca7c91e970bd5eb1bb4c0a7369bc26368c5cb33265baf85745bdc05dbf6011f3454e42a4af2a
diff --git a/net-p2p/tremc/files/0.9.1-fix-startup-crash.patch b/net-p2p/tremc/files/0.9.1-fix-startup-crash.patch
new file mode 100644
index 000000000000..5e67e5d31555
--- /dev/null
+++ b/net-p2p/tremc/files/0.9.1-fix-startup-crash.patch
@@ -0,0 +1,62 @@
+From 0cb919b446eeda41aea8578ae26796ae92a973e5 Mon Sep 17 00:00:00 2001
+From: George Angelopoulos <george@usermod.net>
+Date: Mon, 2 Jul 2018 17:55:38 +0200
+Subject: [PATCH] fix addch ERR crash when starting with no torrents
+
+There was a bug introduced by commit e06d08d:
+ scale_bytes: Simplify this function
+
+tremc would crash when started against a transmission-daemon with no
+torrents.
+
+This was because scale_bytes(0) used to return 0K but now it returns
+0.0K. The expected width of 2 was hardcoded. The new width of 4 causes
+addch() to return ERR because it tries to draw outside the window.
+
+Hardcoding the new width to 4 would resolve this issue. Instead,
+this patch dynamically sets the width returned by scale_bytes().
+This should make the code a tiny bit more readable and maybe avoid this
+issue in the future.
+
+There is one more magic number involved here which I don't see a good
+way of getting rid of. So I made an illustrative comment.
+
+Resolves #15
+---
+ tremc | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/tremc b/tremc
+index 36ae67b..ed898fb 100755
+--- a/tremc
++++ b/tremc
+@@ -883,7 +883,7 @@ class Interface(object):
+ self.focus = -1 # -1: nothing focused; 0: top of list; <# of torrents>-1: bottom of list
+ self.scrollpos = 0 # start of torrentlist
+ self.torrents_per_page = 0 # will be set by manage_layout()
+- self.rateDownload_width = self.rateUpload_width = 2
++ self.rateDownload_width = self.rateUpload_width = len(scale_bytes())
+
+ self.details_category_focus = 0 # overview/files/peers/tracker in details
+ self.focus_detaillist = -1 # same as focus but for details
+@@ -2667,6 +2667,8 @@ class Interface(object):
+ pass
+
+ def draw_global_rates(self):
++ # ↑1.2K ↓3.4M
++ # ^ ^^ => +3
+ rates_width = self.rateDownload_width + self.rateUpload_width + 3
+
+ if self.stats['alt-speed-enabled']:
+@@ -3373,7 +3375,7 @@ def timestamp(timestamp, format="%x %X"):
+ return "%s (%s)" % (absolute, relative)
+
+
+-def scale_bytes(bytes, type='short'):
++def scale_bytes(bytes=0, type='short'):
+ if bytes >= 1099511627776:
+ scaled_bytes = round((bytes / 1099511627776.0), 1)
+ unit = 'T'
+--
+2.26.0
+
diff --git a/net-p2p/tremc/metadata.xml b/net-p2p/tremc/metadata.xml
new file mode 100644
index 000000000000..8e79439699da
--- /dev/null
+++ b/net-p2p/tremc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jchelmertt3@gmail.com</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tremc/tremc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/tremc/tremc-0.9.1.ebuild b/net-p2p/tremc/tremc-0.9.1.ebuild
new file mode 100644
index 000000000000..8306b1e2dfac
--- /dev/null
+++ b/net-p2p/tremc/tremc-0.9.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="ncurses"
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/tremc/tremc"
+SRC_URI="https://github.com/tremc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoip"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ geoip? ( dev-python/geoip-python[${PYTHON_USEDEP}] )
+ ')
+"
+
+# This fixes a crash when starting that was committed after 0.9.1
+PATCHES=( "${FILESDIR}/${PV}-fix-startup-crash.patch" )
+
+# Specify a no-op src_compile so upstream's broken Makefile doesn't get used
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript tremc
+ newbashcomp completion/bash/tremc.sh tremc
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/_tremc
+ doman tremc.1
+ dodoc NEWS README.md
+}