summaryrefslogtreecommitdiff
path: root/net-p2p/ncdc/ncdc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-p2p/ncdc/ncdc-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-p2p/ncdc/ncdc-9999.ebuild')
-rw-r--r--net-p2p/ncdc/ncdc-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/net-p2p/ncdc/ncdc-9999.ebuild b/net-p2p/ncdc/ncdc-9999.ebuild
index f6cebc9b3c0a..e001c6590371 100644
--- a/net-p2p/ncdc/ncdc-9999.ebuild
+++ b/net-p2p/ncdc/ncdc-9999.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="ncurses directconnect client"
HOMEPAGE="https://dev.yorhel.nl/ncdc"
-if [[ "${PV}" == *9999 ]] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="git://g.blicky.net/ncdc.git"
else
@@ -22,7 +22,7 @@ IUSE="geoip"
RDEPEND="
app-arch/bzip2
dev-db/sqlite:3
- dev-libs/glib:2
+ >=dev-libs/glib-2.32:2
net-libs/gnutls:=
sys-libs/ncurses:=[unicode(+)]
sys-libs/zlib:=
@@ -38,16 +38,19 @@ BDEPEND="
src_prepare() {
default
- [[ "${PV}" == *9999 ]] && eautoreconf
+
+ [[ ${PV} == *9999 ]] && eautoreconf
}
src_configure() {
local myeconfargs=(
$(use_with geoip)
)
- if [[ "${PV}" == *9999 ]] ; then
+
+ if [[ ${PV} == *9999 ]] ; then
myeconfargs+=( --enable-git-version )
fi
+
econf "${myeconfargs[@]}"
}