summaryrefslogtreecommitdiff
path: root/net-p2p/ncdc/ncdc-1.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-29 13:13:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-29 13:13:23 +0000
commit04a447f4f2679e9687093f49d8a9ea911fac9a9b (patch)
treeeb97d549c545b418d25f6df1077a2736d8c264fd /net-p2p/ncdc/ncdc-1.24.ebuild
parent3ed757b9cee2e1fe2b18c4630539ccd36f0e0f52 (diff)
gentoo auto-resync : 29:03:2024 - 13:13:23
Diffstat (limited to 'net-p2p/ncdc/ncdc-1.24.ebuild')
-rw-r--r--net-p2p/ncdc/ncdc-1.24.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-p2p/ncdc/ncdc-1.24.ebuild b/net-p2p/ncdc/ncdc-1.24.ebuild
new file mode 100644
index 000000000000..cff76b11e27f
--- /dev/null
+++ b/net-p2p/ncdc/ncdc-1.24.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs verify-sig
+
+DESCRIPTION="Lightweight direct connect client with a friendly ncurses interface"
+HOMEPAGE="https://dev.yorhel.nl/ncdc"
+SRC_URI="
+ https://dev.yorhel.nl/download/${P}.tar.gz
+ verify-sig? ( https://dev.yorhel.nl/download/${P}.tar.gz.asc )
+"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="geoip"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.74:2
+ >=net-libs/gnutls-3:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib
+ geoip? ( dev-libs/libmaxminddb:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/makeheaders
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-yorhel )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/yoranheling.asc
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with geoip)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}