summaryrefslogtreecommitdiff
path: root/net-p2p/mktorrent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /net-p2p/mktorrent
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'net-p2p/mktorrent')
-rw-r--r--net-p2p/mktorrent/Manifest2
-rw-r--r--net-p2p/mktorrent/mktorrent-1.1_p20210130.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/Manifest b/net-p2p/mktorrent/Manifest
index fec41b8513fa..03ee856312a3 100644
--- a/net-p2p/mktorrent/Manifest
+++ b/net-p2p/mktorrent/Manifest
@@ -1,3 +1,5 @@
DIST mktorrent-4c221a05d949a3767a2671de139c6014909daf6b.tar.gz 24574 BLAKE2B e7dcc17aca52c8d1f9d816ce3e89bea5c2b1d7759dba6a00578960b253652506b7e61855d769440056aaa6b0719e6856108ca5b80977152746a648862c71e97b SHA512 49ba2697373a1b40829d50d66faaaeb57fa3893e97283ec2844b447b8e4cf2713d7c0e76e49d3893475f5ce298c3215249751defe0f952d2c52df1bf68f7706c
+DIST mktorrent-de7d011b35458de1472665f50b96c9cf6c303f39.tar.gz 27939 BLAKE2B 3fbf2c98829be21394b6517f2548925fdc83c9199a209aed39a6ba5f31174e34a3290b8c01eaf55e13acd2f15100cf9ecb20073d5fa9d4d1e3b2fb7641f3418d SHA512 4194d73958ba0d43e88a167c46a24e2a92e94b43682f96079a7317fb77f9e48477eddc1556a9785e5c7e5e1745efa7679d1b6b2b41c0ba2aa6df9dae4d3eb489
EBUILD mktorrent-1.1_p20180912.ebuild 956 BLAKE2B 8e97b481c25e4521a9359485b97c5e30669e754f1653b67a2565a747a9cfca81ea6a0581f66cabebc7fac41d7ece65dae8843a1d7757a6364b65ac261fc80e36 SHA512 9181bf4e1028a36b1a3686cb245cd1edbb00f92daa7008d106df2679af34bc1c5750737be48c4381a4a8128245751ada8e926fd34961c4bd937bbb410a4e25aa
+EBUILD mktorrent-1.1_p20210130.ebuild 932 BLAKE2B 1127225642bfc69cfdf5fc56687354f595dbdc1b864f8282e3ad4c82c5271cb4dc29d5b511886aebd2c5b3acdcb4368fe6961dc67ff66534897f8cef22c728a2 SHA512 8f5fd66623777663c0787274e181cb8fa1060247e4b4b71a8c625fb67a56d21bbc49ea5d683ddeb22b07dba05cad12967719eef058116b473c41a456bb1e754b
MISC metadata.xml 476 BLAKE2B 129e62a3ebd8ad740781ed0e6d81930eca9beeb935f270b068e0c09bf450fb7a537e614ae96abf6fdffddf23b8b3103556f641ed96e295d2a6b5d37af453529c SHA512 289ff56364bac0e6df70b9b20827dc2641b57ed8130674a87e41490d79f6615687d77ac2927605960d55d8cc7e5f34036094d19ebfb1a4efb0731acf6cec5842
diff --git a/net-p2p/mktorrent/mktorrent-1.1_p20210130.ebuild b/net-p2p/mktorrent/mktorrent-1.1_p20210130.ebuild
new file mode 100644
index 000000000000..5de284de9187
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.1_p20210130.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="https://github.com/pobrn/mktorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pobrn/mktorrent"
+else
+ COMMIT_ID="de7d011b35458de1472665f50b96c9cf6c303f39"
+ SRC_URI="https://github.com/pobrn/${PN}/archive/${COMMIT_ID}.tar.gz -> ${PN}-${COMMIT_ID}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="threads +ssl debug"
+
+RDEPEND="
+ ssl? ( dev-libs/openssl:0= )
+"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+
+ local myemakeargs=(
+ USE_LARGE_FILES=1
+ DEBUG=$(usex debug)
+ USE_OPENSSL=$(usex ssl)
+ USE_PTHREADS=$(usex threads)
+ )
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}