summaryrefslogtreecommitdiff
path: root/net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild')
-rw-r--r--net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild b/net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild
new file mode 100644
index 000000000000..40a3a3270d56
--- /dev/null
+++ b/net-p2p/mktorrent/mktorrent-1.1_p20180912.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
+HOMEPAGE="https://github.com/Rudde/mktorrent"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Rudde/mktorrent.git"
+else
+ COMMIT_ID="4c221a05d949a3767a2671de139c6014909daf6b"
+ SRC_URI="https://github.com/Rudde/${PN}/archive/${COMMIT_ID}.tar.gz -> ${PN}-${COMMIT_ID}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="threads +ssl libressl debug"
+
+RDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ tc-export CC
+
+ local myemakeargs=(
+ USE_LONG_OPTIONS=1
+ USE_LARGE_FILES=1
+ DEBUG=$(usex debug)
+ USE_OPENSSL=$(usex ssl)
+ USE_PTHREADS=$(usex threads)
+ )
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}