summaryrefslogtreecommitdiff
path: root/net-p2p/gtk-gnutella
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-p2p/gtk-gnutella
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-p2p/gtk-gnutella')
-rw-r--r--net-p2p/gtk-gnutella/Manifest2
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.2.0.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/net-p2p/gtk-gnutella/Manifest b/net-p2p/gtk-gnutella/Manifest
index 927d5b027dc3..c34ce6db1cad 100644
--- a/net-p2p/gtk-gnutella/Manifest
+++ b/net-p2p/gtk-gnutella/Manifest
@@ -1,3 +1,5 @@
DIST gtk-gnutella-1.1.15.tar.xz 19606508 BLAKE2B 3c699f2c5e8b6962265c9fc9bc6720d740c447afb33bef8968e8c8f1f7ec8b88ec3381419cdcee8e2ec8f4e10be2c6e5707d5f89365f347a33990fffd0f18395 SHA512 6b2bee08fba463b66890c8c5d7f7815a8cc4106824e598bed8cffe4601b1e591fc14903ce8d587815257f795c854d459b3a4fa7cc90de2fbc109daef025e5968
+DIST gtk-gnutella-1.2.0.tar.xz 20467452 BLAKE2B 8884c74e5c7ba52ce870289579cb26608fd8eb0fff14986fba40e200181e28908aa42c7a345f1c69dd5b1099135b4a0458d266abdf94361cc0a37b8949867322 SHA512 8d4da23acce22af42b39ca4af2ee4d250cadea9f8c549d712ffdfb797b53311ce8db9fcb38bc1f5547b7df32e95ebc53676bff1127805e867b23d0598b1fa4cd
EBUILD gtk-gnutella-1.1.15.ebuild 1889 BLAKE2B db599d86c14d85badd9d7290c9b717a9b19376c26d233d15d5b75de6c66fa828162ae554bc01e14b418f3555c414df1912f02a70f1e92ba028a63e61e65ea2ee SHA512 c5efa25051678b375791fbd30f7bad7886a4dcc155f8b22fd5af43c898614f84c1a3c6c048e0c379e6b3d6b95d0a0c8b68cd12ab38bf2aa71a72fb35a413304c
+EBUILD gtk-gnutella-1.2.0.ebuild 1906 BLAKE2B 82595556eac617b54ff524b6e2834167ac26c63d432d7ba02c51d185747433f038934c87c4450f001df8aa3560af7e4f5cd3d08c0d6a6e3afef0dbc1cc88d100 SHA512 7d16d7af7134190cac402fb49fc5f82735d902d22d204d827d40dc73a60b2a4fae3339e791361faad473ea1ef5303ec44d548b0c7c5dc81d6c8c72333448861a
MISC metadata.xml 299 BLAKE2B 8e823e2ff9ff16738e4f1d5a5e04264557ee9529ce035978e59a8d1371a8dba5485bde5095e05346ddca410d197e7fbb62f8b651bbe8cd0815396fdeda7935ed SHA512 ab18fa3318fdd64a0e4bff392a88d9f58b1c611c71ee090a767a4a25f75f273dc60a7cfeb7e386e5fbed548d982788c16654584938aec8ef5f6b11cd6d5b3c61
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.2.0.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.2.0.ebuild
new file mode 100644
index 000000000000..d35f1bd7d232
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-1.2.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# eutils: strip-linguas
+inherit eutils toolchain-funcs
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="CC-BY-SA-4.0 GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ <sys-libs/binutils-libs-2.34:=
+ dev-libs/glib:2
+ sys-libs/zlib
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-2.2.5 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ strip-linguas -i po
+
+ echo "# Gentoo-selected LINGUAS" > po/LINGUAS
+ for ling in ${LINGUAS}; do
+ echo $ling >> po/LINGUAS
+ done
+
+ default
+}
+
+src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
+
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
+}
+
+src_compile() {
+ # Build system is not parallel-safe, bug 500760
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install
+ dodoc AUTHORS ChangeLog README TODO
+
+ # Touch the symbols file into the future to avoid warnings from
+ # gtk-gnutella later on, since we will most likely strip the binary.
+ touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
+}