summaryrefslogtreecommitdiff
path: root/net-p2p/go-ethereum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-25 17:37:52 +0000
commit2f51c9978dda4c6e8debca43e4235ecc86914032 (patch)
treebc41e1c4383040034174c327504f702c8517a123 /net-p2p/go-ethereum
parent51536d2fe4697ba9114d611178bb9e20d3d5b729 (diff)
gentoo resync : 25.12.2017
Diffstat (limited to 'net-p2p/go-ethereum')
-rw-r--r--net-p2p/go-ethereum/Manifest2
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index 607e6d45c2c3..3dc8fe4d058f 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1,3 +1,5 @@
DIST go-ethereum-1.7.2.tar.gz 7037907 BLAKE2B eb1e358e42c743a931995e7ee46dc2441356159fc9095e8a886cc6a0495cb2d2e77ee7df4c6dd98bc790397819fc43cdedba6cf28de1e4f3dcdc4dd71106f8e5 SHA512 7bc5957f1523fa5ec67650c4305633aa4c6098a243ef415f9ef56a4e4763eb2ef9f69514ed15810fcdb75f11e87cbd27c4f2af802c32a03be91b37a7b08ea520
+DIST go-ethereum-1.7.3.tar.gz 8188445 BLAKE2B abfa7fff970ea740376e05a56c51a83ba62853b68fd1de1a7161192da294558ea2939427119d00aadcb9e00b8b487e1acfae058e0c5ab6dbe3531e4db0b446cb SHA512 c50391f84b64c924c56d8d052a5c910f94869d86b080cd9b3355a48e094e7f5d4a05a631a57a74619b677067be5da21d6018d18a81bd014bceed43d3626cb017
EBUILD go-ethereum-1.7.2.ebuild 844 BLAKE2B 1b3b946a7bbdad1b891caecbd679ae4136e7ab78a2dcdc79b9922a27d47e6afb421d58f4eae3db1f94e3c7c309503c08a8cc6bacdcd1efcaf05f7777a3be5ffe SHA512 1c62060bbbfd023a6b058192edb08f5b20be10e8727ff322b1c98f4abb2c1ca6cb9f240a5667e5674beee44193d5b011f11e0edffe895b7ed763a2561bca13e4
+EBUILD go-ethereum-1.7.3.ebuild 865 BLAKE2B efb324f64db492900fb57808516caf3285b3f67c8513fb1aec24c8bf10bdd7ed9b4dfa5e04bda732b2c6b00461895c1321f7be9d7ed42796891fe6839241d06f SHA512 60cf846d028395cf438996dec9b7535be060dfd33aca9f773e75ffe455e1affc88d4df95f114780448fe9f4a0f1069c9afae0d7a0cdf3822ae9c3dfc92082bbf
MISC metadata.xml 619 BLAKE2B c425c01f78c66b3c6b0bb4109cad466a9fd5a53ff982aa01c19609836a309e2ebea40c14a5cf850b32f2e3c8f632fca667c864af6e64bfe1738548442464e3bc SHA512 4cd641e4ac75451298d45e0fc37f93b5527d2aa567f1350cd48c02f7a0fd203f4c394e089fddb14ffb1365de98dd31b813ce7c268096054e01e1efbab1310419
diff --git a/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild b/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild
new file mode 100644
index 000000000000..a7fce9166ec3
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-base
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools opencl"
+
+DEPEND="dev-lang/go:=
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ use opencl && export GO_OPENCL=true
+
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+ if use devtools; then
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/evm
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ dobin build/bin/swarm
+ dobin build/bin/wnode
+ fi
+}