summaryrefslogtreecommitdiff
path: root/net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild')
-rw-r--r--net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild b/net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild
new file mode 100644
index 000000000000..415fc5234448
--- /dev/null
+++ b/net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}-dnh${PV}"
+
+DESCRIPTION="Enhanced CTorrent is a BitTorrent console client written in C and C++"
+HOMEPAGE="http://www.rahul.net/dholmes/ctorrent/"
+SRC_URI="mirror://sourceforge/dtorrent/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-CVE-2009-1759.patch
+ "${FILESDIR}"/${P}-negative-ints.patch
+ "${FILESDIR}"/${P}-empty-path-components.patch
+)