summaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /net-p2p/bitcoin-qt
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'net-p2p/bitcoin-qt')
-rw-r--r--net-p2p/bitcoin-qt/Manifest1
-rw-r--r--net-p2p/bitcoin-qt/bitcoin-qt-0.16.0-r1.ebuild188
2 files changed, 189 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-qt/Manifest b/net-p2p/bitcoin-qt/Manifest
index 68efead228ef..cab29d512e84 100644
--- a/net-p2p/bitcoin-qt/Manifest
+++ b/net-p2p/bitcoin-qt/Manifest
@@ -7,5 +7,6 @@ DIST bitcoin-0.16.0.knots20180322.patches.tar.xz 417544 BLAKE2B f14616c81e069434
DIST bitcoin-v0.15.1.tar.gz 7550228 BLAKE2B 0cbb7d0e9d0e5e8eb33502a28289c3f9c86b7c531ed179f7e3e8b601a69a423fa736238a2caae890fd8850eb505533995e578e676860a4014922fbc238185ebb SHA512 a09b6cb64a1649d11e3fd6deeb13a07b1bf4bed504a2fc1c585919459ca8ac1af8e5ecc89dee487359e831a8f12625d54f408f95bb341033d6380b82c290c0d9
DIST bitcoin-v0.16.0.tar.gz 6628305 BLAKE2B 69adb5832e2a708431c06bd8ce695f25cfc2b84e7ccf11e77f40c8ec273146208c70a900d0d32f79790cf67fb359c2731b0cecfc1f27ac2d0c4057228a83aed3 SHA512 7a59de44196a3cd5b75bccfe851e8bd7d5a00ae45b6e771e082326d75846e7c6d1f6d449e18b539b95b25aa12b7b79c462367f1c89438bcd1ca6ec84eb42972c
EBUILD bitcoin-qt-0.15.1.ebuild 7197 BLAKE2B 1aa41f45e03b1c567fda197271007a17f07c3600e6759a4a9dfa0be918ff6878d8b81582647316efbe15d386e6499ebdd54b161ce8afe97c81e10a4ea92ef757 SHA512 7d452b1526df5815d309987beaee84086d4091c198b0e31bc2c80f6a6baeab5a99aff4b4b366d3c06829c070f87683bcabbfb6c14a22d7f551c0b53cd8b5bc5d
+EBUILD bitcoin-qt-0.16.0-r1.ebuild 5135 BLAKE2B 45dc5202f799c7eadc4a92c0e2a5350e79087def0dd5b23e6070aba4d36b04a759c505b25bdf9223320c7440190e07498efa27d03a4996649c9e0d1fd293d4e6 SHA512 18c33d66fec5ba1fc89922e2b5b6a99e8b0ade48e3f6c5c10f41376a2ed484d972059d3bf94ee838541afb57c422da7d05dc7e7089c7fafd8356ba7e6be1d254
EBUILD bitcoin-qt-0.16.0.ebuild 4987 BLAKE2B 356bc3619bcf546e37fdd2e12287455b9eb84fb1198413e13ecb72a02db25a739e8938acb4b4df6f79c07f3d507bfe96319fa0cb01278ef92564754b5885f59a SHA512 009ffb28925b791b6b330ab9c4d8bef8c2bbbc3c1453b12b1b1fe15c5c87235d9f8147d65741395861aea40d37d1959f9cf6a3561d6544ea0a6325932d7e5a27
MISC metadata.xml 1485 BLAKE2B e372351807fa1375c29e2fe88cd15e9aa85111069c8876ae1d806bcd509692fc4d173c37c94a8e5bf63d9d1f25b0ddb8895b2cad4e957c4cb11cd29fe837b8c7 SHA512 ebdf31d2908f1828a57b3728a86b65b1818d7ccee0d2725b3f049fb624cc32d72db48b53ce5f99c98cce7926a3e5840eae375227a5ec6ec6719f7c12ae858c20
diff --git a/net-p2p/bitcoin-qt/bitcoin-qt-0.16.0-r1.ebuild b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.0-r1.ebuild
new file mode 100644
index 000000000000..1e526ce5babf
--- /dev/null
+++ b/net-p2p/bitcoin-qt/bitcoin-qt-0.16.0-r1.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DB_VER="4.8"
+inherit autotools bash-completion-r1 db-use gnome2-utils xdg-utils
+
+BITCOINCORE_COMMITHASH="4b4d7eb255ca8f9a94b92479e6061d129c91a991"
+KNOTS_PV="${PV}.knots20180322"
+KNOTS_P="bitcoin-${KNOTS_PV}"
+
+DESCRIPTION="An end-user Qt GUI for the Bitcoin crypto-currency"
+HOMEPAGE="https://bitcoincore.org/ https://bitcoinknots.org/"
+SRC_URI="
+ https://github.com/bitcoin/bitcoin/archive/${BITCOINCORE_COMMITHASH}.tar.gz -> bitcoin-v${PV}.tar.gz
+ https://bitcoinknots.org/files/0.16.x/${KNOTS_PV}/${KNOTS_P}.patches.txz -> ${KNOTS_P}.patches.tar.xz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~arm ~arm64 ~mips ~ppc ~x86 ~x86-linux"
+
+IUSE="+asm +bip70 +bitcoin_policy_rbf dbus kde +libevent knots libressl +qrcode test upnp +wallet zeromq"
+
+RDEPEND="
+ >=dev-libs/boost-1.52.0:=[threads(+)]
+ >=dev-libs/libsecp256k1-0.0.0_pre20151118:=[recovery]
+ dev-libs/univalue:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ virtual/bitcoin-leveldb
+ bip70? ( dev-libs/protobuf:= )
+ dbus? (
+ dev-qt/qtdbus:5
+ )
+ libevent? ( dev-libs/libevent:= )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
+ qrcode? (
+ media-gfx/qrencode:=
+ )
+ upnp? ( >=net-libs/miniupnpc-1.9.20150916:= )
+ wallet? ( sys-libs/db:$(db_ver_to_slot "${DB_VER}")=[cxx] )
+ zeromq? ( net-libs/zeromq:= )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ knots? (
+ gnome-base/librsvg
+ media-gfx/imagemagick[png]
+ )
+"
+
+DOCS=( doc/bips.md doc/files.md doc/release-notes.md )
+
+S="${WORKDIR}/bitcoin-${BITCOINCORE_COMMITHASH}"
+
+pkg_pretend() {
+ if use knots; then
+ elog "You are building ${PN} from Bitcoin Knots."
+ elog "For more information, see:"
+ elog "https://bitcoinknots.org/files/0.16.x/${KNOTS_PV}/${KNOTS_P}.desc.html"
+ else
+ elog "You are building ${PN} from Bitcoin Core."
+ elog "For more information, see:"
+ elog "https://bitcoincore.org/en/2017/11/11/release-${PV}/"
+ fi
+ if use bitcoin_policy_rbf; then
+ elog "Replace By Fee policy is enabled: Your node will preferentially mine and"
+ elog "relay transactions paying the highest fee, regardless of receive order."
+ else
+ elog "Replace By Fee policy is disabled: Your node will only accept the first"
+ elog "transaction seen consuming a conflicting input, regardless of fee"
+ elog "offered by later ones."
+ fi
+}
+
+src_prepare() {
+ sed -i 's/^\(complete -F _bitcoind \)bitcoind \(bitcoin-qt\)$/\1\2/' contrib/bitcoind.bash-completion || die
+
+ # Save the generic icon for later
+ cp src/qt/res/src/bitcoin.svg bitcoin128.svg || die
+
+ local knots_patchdir="${WORKDIR}/${KNOTS_P}.patches/"
+
+ eapply "${knots_patchdir}/${KNOTS_P}.syslibs.patch"
+
+ if use knots; then
+ eapply "${knots_patchdir}/${KNOTS_P}.f.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.branding.patch"
+ eapply "${knots_patchdir}/${KNOTS_P}.ts.patch"
+ eapply "${FILESDIR}/${P}-fix_mempoolstats.patch"
+ fi
+
+ eapply_user
+
+ if ! use bitcoin_policy_rbf; then
+ sed -i 's/\(DEFAULT_ENABLE_REPLACEMENT = \)true/\1false/' src/validation.h || die
+ fi
+
+ echo '#!/bin/true' >share/genbuild.sh || die
+ mkdir -p src/obj || die
+ echo "#define BUILD_SUFFIX gentoo${PVR#${PV}}" >src/obj/build.h || die
+
+ if use knots; then
+ sed -i 's/^\(Icon=\).*$/\1bitcoinknots/' contrib/debian/bitcoin-qt.desktop || die
+ fi
+ sed -i 's/^\(Categories=.*\)$/\1P2P;Network;Qt;/' contrib/debian/bitcoin-qt.desktop || die
+
+ eautoreconf
+ rm -r src/leveldb src/secp256k1 || die
+}
+
+src_configure() {
+ local my_econf=(
+ $(use_enable asm)
+ $(use_enable bip70)
+ $(use_with dbus qtdbus)
+ $(use_with libevent)
+ $(use_with qrcode qrencode)
+ $(use_with upnp miniupnpc)
+ $(use_enable upnp upnp-default)
+ $(use_enable test tests)
+ $(use_enable wallet)
+ $(use_enable zeromq zmq)
+ --with-gui=qt5
+ --disable-util-cli
+ --disable-util-tx
+ --disable-bench
+ --without-libs
+ --without-daemon
+ --disable-ccache
+ --disable-static
+ --with-system-leveldb
+ --with-system-libsecp256k1
+ --with-system-univalue
+ )
+ econf "${my_econf[@]}"
+}
+
+src_install() {
+ default
+
+ rm -f "${ED%/}/usr/bin/test_bitcoin" || die
+
+ insinto /usr/share/icons/hicolor/scalable/apps/
+ doins bitcoin128.svg
+ if use knots; then
+ newins src/qt/res/src/bitcoin.svg bitcoinknots.svg
+ fi
+
+ insinto /usr/share/applications
+ newins "contrib/debian/bitcoin-qt.desktop" "org.bitcoin.bitcoin-qt.desktop"
+
+ use libevent && dodoc doc/REST-interface.md doc/tor.md
+
+ use zeromq && dodoc doc/zmq.md
+
+ newbashcomp contrib/bitcoind.bash-completion ${PN}
+
+ if use kde; then
+ insinto /usr/share/kservices5
+ doins contrib/debian/bitcoin-qt.protocol
+ dosym "../../kservices5/bitcoin-qt.protocol" "/usr/share/kde4/services/bitcoin-qt.protocol"
+ fi
+}
+
+update_caches() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postinst() {
+ update_caches
+
+ if use libevent; then
+ elog "To have ${PN} automatically use Tor when it's running, be sure your"
+ elog "'torrc' config file has 'ControlPort' and 'CookieAuthentication' setup"
+ elog "correctly, and add your user to the 'tor' user group."
+ fi
+}
+
+pkg_postrm() {
+ update_caches
+}