summaryrefslogtreecommitdiff
path: root/net-p2p/airdcpp-webclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
commitfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (patch)
tree3669828a2d0c5f7cb1a4bfd79be8032aac558282 /net-p2p/airdcpp-webclient
parent9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (diff)
gentoo auto-resync : 03:12:2022 - 02:58:11
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest2
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.3.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 3110eb270c32..691fea84fd30 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -3,5 +3,7 @@ AUX airdcppd.confd 198 BLAKE2B 7d3fbce6527a7f1971f544a37215fa73ed1f19bc5f6c4c3ef
AUX airdcppd.initd 584 BLAKE2B 6e19d6088b26153527fa51e3789c3968647af3f7a2b1fbe2b355587b14eef94b8800a78565ce3bd54f0474542496bfd9f80566c36fcf6f1e51f55c48aa0654ee SHA512 f6de7a576eaef662e73dd488acd956371891278a6fa6c912be864c630a22435541deaca9055c6d7912bf483de228db2cd0bd9c9666a1a436de55112561783721
AUX airdcppd.service 302 BLAKE2B 5e446eb4253c71648e8e6850da4d71e6f16bdb6d82b611882ba4b1ff755073ff611a5502f5f9dbfc94020610ccef9a022add2f85721d464cba94907320618e66 SHA512 79aa352d7943e5297835ec226142661f084a39bd8ccaebace8d4356db995e2eff7c77a9f04ee636bd50e61103bc5a30e83fa126ffa8d77ec068053da2c1b9508
DIST airdcpp-webclient-2.11.2.tar.gz 978294 BLAKE2B cb15e02dc5381cc5f0ecb1b4d65cdd1c4a3d007f3ea1e78a159b8a62af03831318b8f6d8c0692c5a9145dda616627ea97f4bd3eeb1270a7452c7d78bf01d147f SHA512 281d4a9da88f23a4c02eef7f09c4fc2c91c44ac93d932ea4bfe097029b45dbd12a8d04d4ef8b493d261f5dade15b62ed4d564197fbfb2d9d98b9dfcc9a9e6379
+DIST airdcpp-webclient-2.11.3.tar.gz 957277 BLAKE2B fd80433e6c8138c4f60758e4813a056a59586b4f51048a7b717114781fa7b11e5ef0a4cf4fee8441bce6bebc3889acd0ae597c07850da50776454d9ba8230f19 SHA512 59b6189021411fdd3c75ec4744fdb03eb6e6b39b08c1ca9da9519998546a5be5218b4ff2eea7f2d3894fd9146693e807d2cc2396f0f03c074f45cbb4403fe326
EBUILD airdcpp-webclient-2.11.2.ebuild 1428 BLAKE2B 45914928c08e33ea0459fac62aa8c093fed3e0a25281b6e651ff6ae51912fe9d08383e53366dcb786804ecd7926ab7f274833906880e61d9f19d40075d80432a SHA512 6e835a66c0749ee052fd7d0dd2fe55daf2fff67c0f3c49d3605a570be9f7871841e8bff7337e61184f685edd4083fc24afeb207a0e3f9872e96f424d05cbebb9
+EBUILD airdcpp-webclient-2.11.3.ebuild 1383 BLAKE2B ef3dc915c3b556e5a91e761ae2c6ff89c17dc426c2a1ff1cf2931f23152d35d50d6b8bc15985594ed5d1a44dea143258a746351eb3646fa0ff0941d905435477 SHA512 d8dd421d3a3b11d8b6aab097af3adad03ce1cceb4bb3223aac598740c991d8dfee11e34c4f288ae0aa6ca0c25d5a8374ff6d10aa8680a4cd2b3f99105774061b
MISC metadata.xml 805 BLAKE2B f62a540005c5d447e9ddd18b31eb88b1e875161af3b54e8c8753034700a70f28b3d4059d34988a8cf9225c2588ac921b39293e30ed2abf65a2bd0970b75a4628 SHA512 f8ff1e2d21ad685843abdb11672450b08c190203fbaead9170985dcf14332b7deebefb1565df6ce88671a87eb5e22ae80df5eaccf4c42ad49e882dd00b7ec81d
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.3.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.3.ebuild
new file mode 100644
index 000000000000..51a43500c666
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.11.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit cmake python-any-r1 systemd
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~riscv ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug nat-pmp +tbb +webui"
+
+RDEPEND="
+ acct-user/airdcppd
+ acct-group/airdcppd
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist(-)]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ -DINSTALL_WEB_UI=OFF
+ )
+ CMAKE_BUILD_TYPE=$(usex debug Debug Gentoo) cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ systemd_dounit "${FILESDIR}/airdcppd.service"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}