summaryrefslogtreecommitdiff
path: root/net-p2p/airdcpp-webclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-14 01:05:40 +0100
commit76cba73c47c8694e74377004634daca18f2d9c08 (patch)
tree468603ebdc189bcfae77696162761b3be936baea /net-p2p/airdcpp-webclient
parent6957f5c65b02bba533954eabc0b62f5de36be206 (diff)
gentoo resync : 14.04.2018
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest2
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index ea2f0b2e1bcd..10b82d8f32e9 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,5 +1,7 @@
AUX airdcppd.confd 198 BLAKE2B 7d3fbce6527a7f1971f544a37215fa73ed1f19bc5f6c4c3ef90c28b170b84ecd3a82da77b582b69ef442a9a455752192ba4b6b33aeb9a43587c0209fdf380342 SHA512 025ec93c208173771fe697574c9161b9af8d740eab0b1290c8d3857961dc3635339bdb9c18b97fdde6fa7dc8924f4453b9c609ca57e61f1cad9ff47683fb613e
AUX airdcppd.initd 584 BLAKE2B 6e19d6088b26153527fa51e3789c3968647af3f7a2b1fbe2b355587b14eef94b8800a78565ce3bd54f0474542496bfd9f80566c36fcf6f1e51f55c48aa0654ee SHA512 f6de7a576eaef662e73dd488acd956371891278a6fa6c912be864c630a22435541deaca9055c6d7912bf483de228db2cd0bd9c9666a1a436de55112561783721
DIST airdcpp-webclient-2.2.1.tar.gz 845507 BLAKE2B 5d97fe5d25957d870cc5480153acb746ac20bc398e637ccf25a98e42cc905fb445bbc47c211174552e0ee23d1affb0a9265d8499389373bf6622b14428300bd5 SHA512 97c5b32e590b2fc735fe4978c1a173272c55f84fe97212f7cd1e8bd4a279553c1d992573185781aeceafbbe6bb51303ddb2cd164c748fa798993a661f3abfb81
+DIST airdcpp-webclient-2.3.0.tar.gz 880508 BLAKE2B 426c0582ffad734cae2f66826aa04b2db791a110abc79629f4e3b71a69db354b56d213feae6d807f3b7a3f2906aac00fc50c49eaf3dc7d8e09783f59c99ef4e5 SHA512 b1f47c8f500aa684a8cabcff916b6a1e41230d949a35d57c80f13734f6f88f8c3a31d99f64cc1f6e316d26710da894670f130baf78fec5ecf3a70a70f0d7417a
EBUILD airdcpp-webclient-2.2.1.ebuild 1431 BLAKE2B 5a4ec19c01fd32862d96a415cfabd10576b4ae435a33d8788ba2a8ec1dc02e0e30f517a76c36d2392840ae239d7aa3ff9571b7625208c13e2d81c5741469284f SHA512 40fd30c487e3ac0eb2cc80ed3fc40bdda23adb9be229499a47b4abb12e2cff73fd95ab1cc2e920ae8f867d6f3b55cbd441ecee3396bd465b0dbfc0678ad1e902
+EBUILD airdcpp-webclient-2.3.0.ebuild 1440 BLAKE2B 1a2486c19ac9b0814b03811232d648553febaf1277f3b8d88dccf57f3af6078f34b5ed73f6ab14a9b32f822fdbb8ae9a583a8a09ebafbb9271b6641d5929e348 SHA512 1726caffeea7019c6b3ae244c29d787749871c309bafb83974d947c960f7137c51923ad9ef0feed8124055e326291bc2c00aeec938f7e3a6702e7a824475e8c2
MISC metadata.xml 928 BLAKE2B e00d0b7df5302e9129c18fa7250dc30fe34e339cd99e41751d64546d41b0ed328e442825f372acec7207e97f67655c3c05ce99cfda096a7895097210b2d57b1f SHA512 ceccd70826faff18052a1cfe3cdcef1a253ed1227565fa94e865fba8c0a5b8a03535844a3b78d98f6bc26e8a9f29202f0bf1e19fa833d4356ace1e6b26e3936e
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild
new file mode 100644
index 000000000000..9c72310e8ce0
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}