summaryrefslogtreecommitdiff
path: root/net-nntp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /net-nntp
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/Manifest.gzbin1703 -> 1703 bytes
-rw-r--r--net-nntp/tin/Manifest2
-rw-r--r--net-nntp/tin/tin-2.4.5.ebuild73
3 files changed, 75 insertions, 0 deletions
diff --git a/net-nntp/Manifest.gz b/net-nntp/Manifest.gz
index c788cbe125b6..12de2ee4514c 100644
--- a/net-nntp/Manifest.gz
+++ b/net-nntp/Manifest.gz
Binary files differ
diff --git a/net-nntp/tin/Manifest b/net-nntp/tin/Manifest
index d34c6c36a2a6..16994f7e4473 100644
--- a/net-nntp/tin/Manifest
+++ b/net-nntp/tin/Manifest
@@ -1,3 +1,5 @@
DIST tin-2.4.2.tar.xz 1491388 BLAKE2B 16fab433443d5859cc9661790ff837e8f45767e7f45bafc54a8cffc94fd52cb4ee7afb98e579db49c16148b0f521374404a0f26d75a07a24c1c7a1dc5e3a57fe SHA512 70a9957d5bf5af1bb182a3f4e62795cd5862b7282b7fc0c231c3bd02d83950cdbdd502d8a2cc5eae20b29af584e4f794f03378742b47ed93fc5c61ac5bbb01b6
+DIST tin-2.4.5.tar.xz 1559164 BLAKE2B 4efea88c7f76aef91a848c9ed5d82efac640360e41c515015d406e84ed5ce639bbcd17eff29939312ebf83adb8bb84bc7a4f04833cd7cc0781f92b377a0cb31f SHA512 4ec1c4990ce8d9a46204c0064f19c5c2b99848201c37562f8df76de5be84fdd2bcd35cbc3e9f20233f636522e086ac031a5a9cb65bd22a53eda619dcce86adbc
EBUILD tin-2.4.2.ebuild 1724 BLAKE2B 24f674ddf5f8d634e868fa91cf4dba5821abaa17a57765413fb0c057e844684c782c8280632d807db66193dea0f72df5f58e88a109452fffa09e236622584834 SHA512 12a9ecb8e52ecb9f16f2cc086b74afaa4b962310fbb5d29d23f595d10bbedacb27dbcf3a6459a0eccea608165005fff3b9c090523eeab7c4494035302366d7d7
+EBUILD tin-2.4.5.ebuild 1785 BLAKE2B 3421250d779016aff88d38aca85290bbddc186d94c2a2faa6717bb6d3c003c6688c6e1f5c6a3eb242349bd294e7d3a6655366bc0332a5fb09edb6a2c0c38291b SHA512 6cc8dc5e4382e91ee57016ad9e9f0595440949a5f9c2678a0f450ad1cfe3ef801bc1dcc55204bf5a98cfd3a82b33c0873748fe2cb5d207cb1274d18a4b9c12c1
MISC metadata.xml 456 BLAKE2B e606f48de760db9a54bc0d98453c04b71070d0eede202c65ab8ab64ad13557d794c24709c141837cb79468eb063ff6ecf17361385145c2294d90c43f585fe81a SHA512 c73827179e20f2487344e28828b999de4ccf1925a09dac5ae2fbdffbf398c3b147db96f6c69c14e8156bdc84c070dda5b7a24109efb57853ec7a8064a16c8bae
diff --git a/net-nntp/tin/tin-2.4.5.ebuild b/net-nntp/tin/tin-2.4.5.ebuild
new file mode 100644
index 000000000000..280a2c277be4
--- /dev/null
+++ b/net-nntp/tin/tin-2.4.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/stable/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug doc +etiquette gpg idn ipv6 mime nls sasl socks5 spell unicode"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="dev-libs/libpcre
+ dev-libs/uulib
+ gpg? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ mime? ( net-mail/metamail )
+ nls? ( sys-devel/gettext )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+ sys-libs/ncurses:0[unicode?]
+ unicode? ( dev-libs/icu:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ tc-export AR CC RANLIB
+
+ econf \
+ $(use_enable cancel-locks) \
+ $(use_enable debug) \
+ $(use_enable etiquette) \
+ $(use_enable gpg pgp-gpg) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with mime metamail /usr) \
+ $(use_with socks5 socks) $(use_with socks5) \
+ $(use_with spell ispell /usr) \
+ --disable-mime-strict-charset \
+ --enable-echo \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --with-coffee \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ --with-pcre=/usr \
+ --with-screen=${screen}
+}
+
+src_compile() {
+ # To build from the root dir you have to call `make build`, not just
+ # `make`.
+ emake build
+}
+
+src_install() {
+ default
+
+ # File collision?
+ rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
+ use doc && dodoc doc/{*.sample,*.txt}
+
+ insinto /etc/tin
+ doins doc/tin.defaults
+}