summaryrefslogtreecommitdiff
path: root/net-nntp/slrn/slrn-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
commit4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (patch)
treef7640b8b96a04499f1ce44a2cad122d45a8373bd /net-nntp/slrn/slrn-1.0.3.ebuild
parent48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (diff)
gentoo resync : 21.12.2017
Diffstat (limited to 'net-nntp/slrn/slrn-1.0.3.ebuild')
-rw-r--r--net-nntp/slrn/slrn-1.0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-nntp/slrn/slrn-1.0.3.ebuild b/net-nntp/slrn/slrn-1.0.3.ebuild
new file mode 100644
index 000000000000..10dd1762c3c2
--- /dev/null
+++ b/net-nntp/slrn/slrn-1.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P}a"
+
+DESCRIPTION="A s-lang based newsreader"
+HOMEPAGE="http://slrn.sourceforge.net/"
+SRC_URI="https://jedsoft.org/releases/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="canlock libressl nls ssl uudeview"
+
+RDEPEND="app-arch/sharutils
+ >=sys-libs/slang-2.2.3
+ virtual/mta
+ canlock? ( net-libs/canlock )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ uudeview? ( dev-libs/uulib )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-make.patch )
+
+src_configure() {
+ econf \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-slrnpull \
+ $(use_with canlock) \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ $(use_with uudeview uu)
+}