summaryrefslogtreecommitdiff
path: root/net-nntp/inn/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-nntp/inn/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-nntp/inn/files')
-rw-r--r--net-nntp/inn/files/inn-2.5.3-ar.patch37
-rw-r--r--net-nntp/inn/files/inn-2.5.3-tests.patch19
-rw-r--r--net-nntp/inn/files/innd21
-rw-r--r--net-nntp/inn/files/innd-r122
4 files changed, 99 insertions, 0 deletions
diff --git a/net-nntp/inn/files/inn-2.5.3-ar.patch b/net-nntp/inn/files/inn-2.5.3-ar.patch
new file mode 100644
index 000000000000..ac4f8158c44f
--- /dev/null
+++ b/net-nntp/inn/files/inn-2.5.3-ar.patch
@@ -0,0 +1,37 @@
+Use system AR.
+
+Gentoo bug #461254.
+
+--- lib/Makefile
++++ lib/Makefile
+@@ -53,7 +53,7 @@
+ -rpath $(PATHLIB) -version-info 2:0:0
+
+ libinn.a: $(OBJECTS)
+- ar r $@ $(OBJECTS)
++ $(AR) r $@ $(OBJECTS)
+ $(RANLIB) libinn.a
+
+ .c.o .c.lo:
+--- storage/Makefile
++++ storage/Makefile
+@@ -55,7 +55,7 @@
+ -rpath $(PATHLIB) -version-info 2:0:0
+
+ libstorage.a: $(OBJECTS)
+- ar r $@ $(OBJECTS)
++ $(AR) r $@ $(OBJECTS)
+ $(RANLIB) libstorage.a
+
+ # Make.methods is included in the distribution tarball since some non-GNU
+--- history/Makefile
++++ history/Makefile
+@@ -51,7 +51,7 @@
+ -rpath $(PATHLIB) -version-info 2:0:0
+
+ libinnhist.a: $(OBJECTS)
+- ar r $@ $(OBJECTS)
++ $(AR) r $@ $(OBJECTS)
+ $(RANLIB) libinnhist.a
+
+ # Try to set up these rules so that buildconfig is only run once.
diff --git a/net-nntp/inn/files/inn-2.5.3-tests.patch b/net-nntp/inn/files/inn-2.5.3-tests.patch
new file mode 100644
index 000000000000..6511508308d6
--- /dev/null
+++ b/net-nntp/inn/files/inn-2.5.3-tests.patch
@@ -0,0 +1,19 @@
+Certain filesystems (such as reiserfs) cannot properly report
+the number of free inodes. In this case, inndf reports an absurdly
+high number instead of nothing, which standard df does.
+There seems to be some confusion about which FOO_MAX is returned,
+so this patch adds an actual value known to be returned.
+
+See bug #348490.
+
+--- tests/util/inndf.t
++++ tests/util/inndf.t
+@@ -62,7 +62,7 @@
+ real=`df -i . | sed 1d | awk '{ print $4 }'`
+ fi
+ try=`$inndf -i .`
+- if [ "$try" = 4294967295 ] ; then
++ if [ "$try" = 4294967295 ] || [ "$try" = 2147483647 ] ; then
+ printcount "ok"
+ else
+ diff=`expr "$real" - "$try"`
diff --git a/net-nntp/inn/files/innd b/net-nntp/inn/files/innd
new file mode 100644
index 000000000000..c45d45b830cb
--- /dev/null
+++ b/net-nntp/inn/files/innd
@@ -0,0 +1,21 @@
+#!/sbin/openrc-run
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting innd"
+ checkpath -d -m 0755 -o news:news /var/run/news
+ start-stop-daemon --start --user news --exec /usr/lib/news/bin/rc.news
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping innd"
+ start-stop-daemon --start --user news --exec /usr/lib/news/bin/rc.news -- stop
+ sleep 2
+ eend $?
+}
diff --git a/net-nntp/inn/files/innd-r1 b/net-nntp/inn/files/innd-r1
new file mode 100644
index 000000000000..071797e50796
--- /dev/null
+++ b/net-nntp/inn/files/innd-r1
@@ -0,0 +1,22 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ checkpath -d -m 0755 -o news:news /run/news
+ start-stop-daemon --start --user news --pidfile /run/news/${SVCNAME}.pid \
+ --exec /usr/lib/news/bin/rc.news
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --start --user news --exec /usr/lib/news/bin/rc.news -- stop
+ sleep 2
+ eend $?
+}