summaryrefslogtreecommitdiff
path: root/net-nds
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-01 11:42:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-01 11:42:50 +0100
commitb447ac3a6d1bb09ddb6a5686620670e223b37642 (patch)
tree4d6d1ca6d418b0dc7c50e0e94cef5038f5fb2483 /net-nds
parent9a92076d428b51966bd8d699427341e5500b3a8a (diff)
gentoo auto-resync : 01:10:2023 - 11:42:49
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/Manifest.gzbin2392 -> 2393 bytes
-rw-r--r--net-nds/ldapvi/Manifest2
-rw-r--r--net-nds/ldapvi/files/ldapvi-1.7-fix-missing-on_exit-musl.patch61
-rw-r--r--net-nds/ldapvi/ldapvi-1.7_p20101214-r6.ebuild62
4 files changed, 125 insertions, 0 deletions
diff --git a/net-nds/Manifest.gz b/net-nds/Manifest.gz
index 44f0b5ca2888..2171285bec8f 100644
--- a/net-nds/Manifest.gz
+++ b/net-nds/Manifest.gz
Binary files differ
diff --git a/net-nds/ldapvi/Manifest b/net-nds/ldapvi/Manifest
index 9c64f6095589..088ce26b5df6 100644
--- a/net-nds/ldapvi/Manifest
+++ b/net-nds/ldapvi/Manifest
@@ -1,4 +1,6 @@
AUX ldapvi-1.7-fix-implicit-function-declarations.patch 2185 BLAKE2B 0cf16e855a221a78106a8c1e4d57b50fead25b1ea871798b1a445cc0f7af1073cf0fc7ce7dd4b1962d4e7c5da844fb1e97ad51508b292447f88338c87bf76856 SHA512 f8b9a139b371074a4677a78a024c1e5134c1110a0c7dbfe702da9efe6275ecdcca4c40f746ec99f157a2cb159bce447ef38d94e2391dc7cb40f844d14fa14539
+AUX ldapvi-1.7-fix-missing-on_exit-musl.patch 1513 BLAKE2B bf462c82872d01642bfccc66742091c839dfac8676a98cca49bb3863196d3a607fe46fb7799fd70ba095b902f7017218c09a4aa451d38c0da53611312a222587 SHA512 163b887a2c151023541444ed0a260e084d795668dd4d6ca6fb15d983f9e1bf93145beff9b610118afa74a927d901661a4cb964d223bb6eb183e3bf945402c711
DIST ldapvi-1.7_p20101214.tar.bz2 1490491 BLAKE2B 21bb7b6113e89ce848e7a8efcec063dbfe9c32331c1125456a96dc6edc4e09d17245307a041a7d7804fac20bcce5b38677d719fb53d993fb874134bbd4d4df19 SHA512 2d2a744a36364793f406f37ecf6e546914d697457dec37b81544f4979f4c692756b2a1c3ea6fcbaba5e3238b2bf758ab3e0bd9a9a0794c4da734d65286bd5925
EBUILD ldapvi-1.7_p20101214-r5.ebuild 1107 BLAKE2B 5d4b2604aa0ec38e11c7c99ebb1cd91796661eb26565be24411bf27520c682ad809bda7a2b8651cc9796bb3a1c75fbae830718f39096d55d31797fd604e217c8 SHA512 207af68618c2954514ebeed661e3d8b2f9eaa2d303f5aff946b829feed3767a5f3a5039d1e63a5e2f4974b56d695f21345dc7b08f09a165205394cd6648750de
+EBUILD ldapvi-1.7_p20101214-r6.ebuild 1166 BLAKE2B 965db608a7cbbdb3db34277f77ea2a90c547554d82f77ba9e44ef2d39d592fa65a075e1218a96888991246c02e37827d35417f3006a958202c4077072b1d9f0d SHA512 415e53f5cb83c95a025529fcab4f2f21bd68197ee2c1b1cd21d33edc5541d5c18aefa7136f853fbc02b34ad88a999da24307f17a2aeeb47d3c2d8f1790c83365
MISC metadata.xml 279 BLAKE2B ed38c142d61f6990bbe12ecd7766fc9e0f1a1577ecbf8eb856d9b235171dbc8ec9a8632c02cfddfe6c587ed3144a417161d00e7818400f56758d4b08289e51d1 SHA512 f20b66bb26c85e5b3c2ecc1a29c136979ee430b88858c79cc673583301f7d3df9aa41dd3c18f432a1580dd5549431e9e7b6e7359f24b6f56f8e20f9bd7f478fa
diff --git a/net-nds/ldapvi/files/ldapvi-1.7-fix-missing-on_exit-musl.patch b/net-nds/ldapvi/files/ldapvi-1.7-fix-missing-on_exit-musl.patch
new file mode 100644
index 000000000000..b883e412d327
--- /dev/null
+++ b/net-nds/ldapvi/files/ldapvi-1.7-fix-missing-on_exit-musl.patch
@@ -0,0 +1,61 @@
+Use internal on_exit function as on_exit is not available on musl libc Bug: https://bugs.gentoo.org/898066
+--- a/common.h
++++ b/common.h
+@@ -372,3 +372,7 @@ void sasl_defaults_free(tsasl_defaults *sd);
+ int ldapvi_sasl_interact(LDAP *ld, unsigned flags, void *defaults, void *p);
+
+ void fdcp(int fdsrc, int fddst);
++
++#ifndef HAVE_ON_EXIT
++int on_exit(void (*function)(int, void *), void *arg);
++#endif
+--- a/ldapvi.c
++++ b/ldapvi.c
+@@ -17,6 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++#include <stdio.h>
+ #include <curses.h>
+ #include <signal.h>
+ #include <term.h>
+--- a/misc.c
++++ b/misc.c
+@@ -15,6 +15,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++#include <stdio.h>
+ #include <curses.h>
+ #include <term.h>
+ #include "common.h"
+--- a/parse.c
++++ b/parse.c
+@@ -18,6 +18,7 @@
+ #define _XOPEN_SOURCE
+ #include <unistd.h>
+ #include <crypt.h>
++#include <stdio.h>
+ #include "common.h"
+
+ #define fast_g_string_append_c(gstring, c) \
+--- a/parseldif.c
++++ b/parseldif.c
+@@ -17,6 +17,7 @@
+ */
+ #define _XOPEN_SOURCE
+ #include <unistd.h>
++#include <stdio.h>
+ #include "common.h"
+
+ #define fast_g_string_append_c(gstring, c) \
+--- a/port.c
++++ b/port.c
+@@ -31,6 +31,7 @@
+ #include <unistd.h>
+
+ #include "config.h"
++#include "common.h"
+
+ #if defined(HAVE_OPENSSL)
+ #include <openssl/sha.h>
diff --git a/net-nds/ldapvi/ldapvi-1.7_p20101214-r6.ebuild b/net-nds/ldapvi/ldapvi-1.7_p20101214-r6.ebuild
new file mode 100644
index 000000000000..13736b4b86ef
--- /dev/null
+++ b/net-nds/ldapvi/ldapvi-1.7_p20101214-r6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Manage LDAP entries with a text editor"
+HOMEPAGE="http://www.lichteblau.com/ldapvi/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}"/${P}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="gnutls sasl"
+
+RDEPEND="
+ dev-libs/popt
+ dev-libs/glib:2
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ virtual/libcrypt:=
+ gnutls? (
+ net-libs/gnutls:=
+ net-nds/openldap[gnutls]
+ )
+ !gnutls? (
+ dev-libs/openssl:=
+ net-nds/openldap[ssl]
+ )
+ sasl? ( dev-libs/cyrus-sasl:2[ssl] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7-fix-implicit-function-declarations.patch"
+ "${FILESDIR}/${PN}-1.7-fix-missing-on_exit-musl.patch"
+)
+
+src_prepare() {
+ default
+
+ # bug #459478
+ sed -i \
+ -e '/^AC_SEARCH_LIBS/s:curses ncurses:curses ncurses tinfo:' \
+ configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-libcrypto=$(usex gnutls gnutls openssl)
+}
+
+src_install() {
+ dobin ldapvi
+ doman ldapvi.1
+ dodoc NEWS manual/{bg.png,html.xsl,manual.{css,xml}}
+}