summaryrefslogtreecommitdiff
path: root/net-nds
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-30 11:49:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-30 11:49:23 +0000
commit840a65e2af3f2cc7527e723a28f6e627a9592fb7 (patch)
tree66e124d9e55317fe43e1af9984e75c156df5cb29 /net-nds
parent73e3b099187df1c4f2df056e45f345a56d2535aa (diff)
gentoo auto-resync : 30:01:2024 - 11:49:23
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/Manifest.gzbin2396 -> 2397 bytes
-rw-r--r--net-nds/nsscache/Manifest2
-rw-r--r--net-nds/nsscache/nsscache-0.49.ebuild26
3 files changed, 14 insertions, 14 deletions
diff --git a/net-nds/Manifest.gz b/net-nds/Manifest.gz
index ec339b486be7..1766c4e1c63f 100644
--- a/net-nds/Manifest.gz
+++ b/net-nds/Manifest.gz
Binary files differ
diff --git a/net-nds/nsscache/Manifest b/net-nds/nsscache/Manifest
index 4ae01d1641d6..7d953b9bdae8 100644
--- a/net-nds/nsscache/Manifest
+++ b/net-nds/nsscache/Manifest
@@ -1,3 +1,3 @@
DIST nsscache-0.49.tar.gz 128598 BLAKE2B 2d0c9c2818f7dbab44bd4fd17b7e1dceb3f1a236c18c96be4cc5dcf8329c748c0b1f8dc0f462e186458b3ede380ebc408fe56bfe21bc5aa8720a15122f90cec6 SHA512 941f6fcb8f52294f910dcf8e1aaf7f07bf83e7812d9325a709248c49013b46a959c6abdbaafd161ddcef96525d02aa939c68c9548841a6b66b94417f86b67527
-EBUILD nsscache-0.49.ebuild 2121 BLAKE2B a7cba63475f4708a36351d6f397f3447859eeb31eba4b4d6f8a5955986b588e4b3c5371ab52fffaeb6fcf159ec36d3903a921b0dd33ce84d39c4dc3586c3e121 SHA512 acbc1452dfb23e9771f3eaecc8200899ac2f3763e8a5c728366796686832bffa164515c722acc95246a88cec0ac398634169ff262564dd4babd8177d54c4b6ca
+EBUILD nsscache-0.49.ebuild 2232 BLAKE2B ac0b442d25d723a9ce081c4cd9d24e239697777c9c5f0f913462e4189f5a62b82fdbd1acf146a83c0f4727178b0ba8b2be0389729991db2aa23479c12e7af12d SHA512 e93075142b809c55f9aa6b570b8be4ef6856fb22611cd04c6e554cdf4b3e69411207f40b811324a0e40ca0b5e8d973494beae117078cd3e5c09b1bec3012c04b
MISC metadata.xml 467 BLAKE2B 49769763ea33cf2fa9ff8614ee16353cd0454bc9ed634787f2782493949d7f25bac9720ad2f0c16d8f6ce45d3b4e79b0f8a6592a7bcc5668ad3c834094584406 SHA512 e3f7f6bdc779dfc2cf63e00940de55faa22a7a8ac4de539c4785c13eff97faf541bd1badb5616a3b8d0a53eabe278290216830fefa4c683d5654d93af98149a7
diff --git a/net-nds/nsscache/nsscache-0.49.ebuild b/net-nds/nsscache/nsscache-0.49.ebuild
index 90f77100fc73..2674e1db5d26 100644
--- a/net-nds/nsscache/nsscache-0.49.ebuild
+++ b/net-nds/nsscache/nsscache-0.49.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,21 +12,22 @@ DESCRIPTION="commandline tool to sync directory services to local cache"
HOMEPAGE="https://github.com/google/nsscache"
SRC_URI="https://github.com/google/nsscache/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
+# upstream *sources* say "or later", but upstream metadata does not include the
+# 'or later' clause.
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nsscache s3 test"
-# testing requires local network (e.g. spin up slapd, httpd)
-#PROPERTIES="test_network"
-#RESTRICT="test"
-
# Optional extras:
# TODO: gcs? ( https://pypi.org/project/google-cloud-storage/ )
#
# Testing:
# *unit* tests do not require networking.
# *integration* tests require openldap's slapd and networking
+#
+# The ebuild runs the unit testing explicitly, as upstream uses Docker to run
+# the integration tests.
RDEPEND="
nsscache? ( >=sys-auth/libnss-cache-0.10 )
>=dev-python/python-ldap-3.4[${PYTHON_USEDEP}]
@@ -35,11 +36,13 @@ RDEPEND="
DEPEND="${RDEPEND}
dev-python/packaging[${PYTHON_USEDEP}]
test? (
- dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
)"
S="${WORKDIR}/${PN}-version-${PV}"
+distutils_enable_tests pytest
+
python_prepare_all() {
# nsscache.conf is example only, and should be installed in docs.
# Default config tries $PREFIX/config/nsscache.conf
@@ -55,6 +58,7 @@ python_prepare_all() {
}
python_compile() {
+ # Yes, tell setup.py to be verbose
distutils-r1_python_compile --verbose
}
@@ -70,10 +74,8 @@ python_install() {
-iname '*_test.py*' \
-o -iname '*_test.*.py*' \
\) \
- -delete
-
- # Ignore any exit code from find.
- return 0
+ -delete \
+ || die "find failed"
}
python_install_all() {
@@ -84,5 +86,3 @@ python_install_all() {
keepdir /var/lib/nsscache
}
-
-distutils_enable_tests pytest