summaryrefslogtreecommitdiff
path: root/net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild')
-rw-r--r--net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild b/net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild
new file mode 100644
index 000000000000..9c758522b57f
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+DESCRIPTION="Network Information Service tools"
+HOMEPAGE="https://www.thkukuk.de/nis/"
+SRC_URI="https://github.com/thkukuk/yp-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ppc ppc64 ~riscv ~sparc x86"
+IUSE="nls"
+
+# Always uses libtirpc if present
+DEPEND="
+ net-libs/libtirpc:=
+ >=net-libs/libnsl-1.2.0:0=
+ virtual/libcrypt:=
+ nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --sysconfdir="${EPREFIX}"/etc/yp \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ insinto /etc/yp
+ doins etc/nicknames
+
+ systemd_dounit "${FILESDIR}"/domainname.service
+ systemd_install_serviced "${FILESDIR}"/domainname.service.conf
+}