summaryrefslogtreecommitdiff
path: root/net-nds/yp-tools/yp-tools-4.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-nds/yp-tools/yp-tools-4.2.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-nds/yp-tools/yp-tools-4.2.2.ebuild')
-rw-r--r--net-nds/yp-tools/yp-tools-4.2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-nds/yp-tools/yp-tools-4.2.2.ebuild b/net-nds/yp-tools/yp-tools-4.2.2.ebuild
new file mode 100644
index 000000000000..a566743bf7ce
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-4.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit systemd
+
+DESCRIPTION="Network Information Service tools"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="http://www.linux-nis.org/download/yp-tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+src_configure () {
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/yp \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ insinto /etc/yp
+ doins etc/nicknames
+
+ systemd_dounit "${FILESDIR}/domainname.service"
+ systemd_install_serviced "${FILESDIR}"/domainname.service.conf
+}