summaryrefslogtreecommitdiff
path: root/net-nds/shelldap/shelldap-1.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /net-nds/shelldap/shelldap-1.5.1.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'net-nds/shelldap/shelldap-1.5.1.ebuild')
-rw-r--r--net-nds/shelldap/shelldap-1.5.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-nds/shelldap/shelldap-1.5.1.ebuild b/net-nds/shelldap/shelldap-1.5.1.ebuild
new file mode 100644
index 000000000000..eca62dabfd3d
--- /dev/null
+++ b/net-nds/shelldap/shelldap-1.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=noslotop
+inherit eutils perl-module
+
+DESCRIPTION="A handy shell-like interface for browsing LDAP servers and editing their content"
+HOMEPAGE="https://github.com/mahlonsmith/shelldap https://bitbucket.org/mahlon/shelldap/"
+SRC_URI="https://github.com/mahlonsmith/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+readline sasl +ssl"
+
+RDEPEND="dev-perl/Algorithm-Diff
+ sasl? ( dev-perl/Authen-SASL )
+ dev-perl/IO-Socket-SSL
+ dev-perl/perl-ldap
+ dev-perl/TermReadKey
+ readline? ( dev-perl/Term-ReadLine-Gnu )
+ dev-perl/Term-Shell
+ dev-perl/Tie-IxHash
+ dev-perl/YAML-Syck
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-Getopt-Long
+ virtual/perl-Digest-MD5"
+
+src_configure() { :; }
+
+src_compile() {
+ pod2man --name "${PN}" < "${PN}" > "${PN}.1" || die 'creating manpage failed'
+}
+
+src_install() {
+ doman "${PN}.1"
+ dobin "${PN}"
+ dodoc USAGE
+}