summaryrefslogtreecommitdiff
path: root/net-nds/nsscache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /net-nds/nsscache
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'net-nds/nsscache')
-rw-r--r--net-nds/nsscache/Manifest3
-rw-r--r--net-nds/nsscache/nsscache-0.39-r1.ebuild66
-rw-r--r--net-nds/nsscache/nsscache-0.47.ebuild72
3 files changed, 141 insertions, 0 deletions
diff --git a/net-nds/nsscache/Manifest b/net-nds/nsscache/Manifest
index c63b0c801d90..f6d62d3113d4 100644
--- a/net-nds/nsscache/Manifest
+++ b/net-nds/nsscache/Manifest
@@ -1,4 +1,7 @@
DIST nsscache-0.30-r3-gentoo-authorized-keys-command.py 11974 BLAKE2B 4272bab8d85ef0f39c8b26fd035009d3c77dd629fd7853e0072232393d329af1885ce44c4877d7718a37154661d9c85bb1f5276463875f9dfbbd023106d9d15a SHA512 b660a6ae19e6e42efbb07d0a368704706b0a0bd1bf0b2c84855f0d1c00d4cda80872432f5a25384d0c27e99bf60072beb12975bcfa0201b52fa040d0e6bc2da2
DIST nsscache-0.39.tar.gz 127896 BLAKE2B 8383ca53ee5cf2f84e4485722d35598b624005bb32073696a23daa1061c0b057d26333cdee9c97cedcb99daa8c61362719d80b01b216c163a327cd4edeabeefd SHA512 f93cec949302f21bc5989ab3192302a32349ee4ae98e2f05f169cca8a16a821f39857cb0fff52c7b54552828684b4723d22e44f97525a01577ab89bd159e0376
+DIST nsscache-0.47.tar.gz 126225 BLAKE2B f238d4a6565038420dee7359edadf348a0e5fb581b8238b23d3835cc10ad9676917bfa6573c6a1d462d7afee36398954744ff2d498b4c1ed3459666b3aa6ad5c SHA512 94cd9a62169146f1e10f78476a950dfc708b6c2063cffed3617bbfa9c43aaf134b1f038a94079df408e168877d32f07b64b61f048d34fed283828cc75e7dd2cf
+EBUILD nsscache-0.39-r1.ebuild 1556 BLAKE2B ed22187c5838dce7e7c9ddbc612cc4984d4a1b4d630b46ce34ea536bc88c30a703a932884e2e23835a02c0bb65ee386c200708320917cfcf1399be9d10ccd69a SHA512 1ba68e189a36ae300b159395564b6253e9564fd6615c157113d6675c432380244a7c5a2de1fc893b95edf19c62afdf5924e7bbd028910d09ade9e203e71bcb65
EBUILD nsscache-0.39.ebuild 1551 BLAKE2B e887301bcc5d0c5a2ed4a3cb8394634377754b562bcc9d00f611724f63f3c2f2a4c37b517c72b961d5a87694b0618f432cc963af12269d7c9e45fada4f18b7de SHA512 dc98faed7dc9f0b4e591eaac4b13b3ba8c452574b5fc82d41115a2cadb464e1dd07e0e682969118459a7f216d6f26aa488912be461ce4058dbff0ea9660b9038
+EBUILD nsscache-0.47.ebuild 1822 BLAKE2B df4592aa8b982592164b814872a7ffa140edec7037ca3afe0f3804213f263266b60a6c40347afca1883880b8eeae4990c09b1b020f1fe60b9a1ff3f05d6741c5 SHA512 522f238ff19663fcd8536561bc43b9601dca0f36d58fb0e4bb5007715e39976016a53dbe3d5d81ff7ed5522ab25f6d2b7c10216a9350927e931f90505d3103e0
MISC metadata.xml 467 BLAKE2B 49769763ea33cf2fa9ff8614ee16353cd0454bc9ed634787f2782493949d7f25bac9720ad2f0c16d8f6ce45d3b4e79b0f8a6592a7bcc5668ad3c834094584406 SHA512 e3f7f6bdc779dfc2cf63e00940de55faa22a7a8ac4de539c4785c13eff97faf541bd1badb5616a3b8d0a53eabe278290216830fefa4c683d5654d93af98149a7
diff --git a/net-nds/nsscache/nsscache-0.39-r1.ebuild b/net-nds/nsscache/nsscache-0.39-r1.ebuild
new file mode 100644
index 000000000000..7f30d2de2a53
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.39-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="https://github.com/google/nsscache"
+SCRIPT_A='nsscache-0.30-r3-gentoo-authorized-keys-command.py'
+SRC_URI="
+ https://github.com/google/nsscache/archive/version/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~robbat2/${SCRIPT_A}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb nsscache s3"
+RESTRICT="test" # requires network
+
+DEPEND="
+ dev-python/ldap3[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ nsscache? ( >=sys-auth/libnss-cache-0.10 )"
+
+S="${WORKDIR}/${PN}-version-${PV}"
+
+python_prepare_all() {
+ sed -i \
+ -e "/setup_requires/s,'pytest-runner',,g" \
+ -e '/tests_require/s,\[.*\],[],g' \
+ setup.py || die
+ sed -i \
+ -e '/test=pytest/d' \
+ setup.cfg || die
+ sed -i \
+ -e '/pytest/d' \
+ requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile --verbose
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_scriptinto /usr/libexec/nsscache
+ python_newexe "${DISTDIR}"/"${SCRIPT_A}" authorized-keys-command.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron CONTRIBUTING.md README.md
+
+ keepdir /var/lib/nsscache
+}
diff --git a/net-nds/nsscache/nsscache-0.47.ebuild b/net-nds/nsscache/nsscache-0.47.ebuild
new file mode 100644
index 000000000000..9d67d529c0be
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.47.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="https://github.com/google/nsscache"
+SCRIPT_A='nsscache-0.30-r3-gentoo-authorized-keys-command.py'
+SRC_URI="
+ https://github.com/google/nsscache/archive/version/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~robbat2/${SCRIPT_A}"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS="~amd64 ~x86"
+KEYWORDS="" # pending infra testing
+IUSE="nsscache s3 test"
+RESTRICT="test" # requires network
+
+#test? ( dev-python/pytest-cov[${PYTHON_USEDEP}] dev-python/mox3[${PYTHON_USEDEP}] )
+DEPEND="
+ dev-python/ldap3[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ s3? ( dev-python/boto3[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}
+ nsscache? ( >=sys-auth/libnss-cache-0.10 )"
+
+S="${WORKDIR}/${PN}-version-${PV}"
+
+python_prepare_all() {
+ # If tests are disabled in the ebuild, disable in setup
+ if [[ "${RESTRICT/test}" != "$RESTRICT" ]]; then
+ sed -i \
+ -e "/setup_requires/s,'pytest-runner',,g" \
+ -e '/tests_require/s,\[.*\],[],g' \
+ setup.py || die
+ sed -i \
+ -e '/test=pytest/d' \
+ setup.cfg || die
+ sed -i \
+ -e '/pytest/d' \
+ requirements.txt || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile --verbose
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_scriptinto /usr/libexec/nsscache
+ python_newexe "${DISTDIR}"/"${SCRIPT_A}" authorized-keys-command.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron CONTRIBUTING.md README.md
+
+ keepdir /var/lib/nsscache
+}
+
+[[ "${RESTRICT/test}" != "$RESTRICT" ]] && distutils_enable_tests pytest