summaryrefslogtreecommitdiff
path: root/net-nds/gssproxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-nds/gssproxy
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-nds/gssproxy')
-rw-r--r--net-nds/gssproxy/Manifest2
-rw-r--r--net-nds/gssproxy/gssproxy-0.8.3.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/net-nds/gssproxy/Manifest b/net-nds/gssproxy/Manifest
index d5b9bddb2822..57c561a815f2 100644
--- a/net-nds/gssproxy/Manifest
+++ b/net-nds/gssproxy/Manifest
@@ -1,4 +1,6 @@
AUX gssproxy 279 BLAKE2B 8413b5e581d084933a1851d3c8be363c07a750180ce72629297466d7afcfdf2dfd94c877883f4503314b5b25b608634f3258c3c1369948b6263dcd9c60b0aabc SHA512 c36d646ee1b7c2e172192782c8d54e51ffb13d75c7afbcd7c67872cfa2baf994a2582bb2b423b27e591051ca2e5b3969dc1f26e7f7a277999537d85e624bcab4
DIST gssproxy-0.8.2.tar.gz 563300 BLAKE2B 104637af6f43d118ef5194ee8bdfd0a8a8155df43691ac80394de0482f718f2672996b698a80d5c4db7bdc1b164be7f8dc6ffd9a5346affd5923b78362f10333 SHA512 68ce39b36ee83d77da19e9a9fb322ba901366999828a2b427bc2275c4187b4d2291de140c202cce02bdf53eb5cf64da2fafa022ea482258c102f28b0af5d7c63
+DIST gssproxy-0.8.3.tar.gz 565100 BLAKE2B a8b3d96ca0b1cc314af3b63cc5959c9b48287ea0169ea75f8a8902bbd5757542fd24e1fa3f603b2a7d4c15878600145bf5a27e880e935a7a037ca3ebc9fcfb9c SHA512 144b10ec4e19ad2ded5ae57adf1ca311e2fc6c2b97e202eedde69d82c8d50afc0459ac36c7fc5d5290184eb68547a696b33e8a069fde43478104ac26b2c98bc2
EBUILD gssproxy-0.8.2.ebuild 2786 BLAKE2B 0eadc99c60f0cde3ca9a5dc9554b9934d606878d0bc3d047559e4f2d93355d24736a103bbe4699bc078238b762bc07db4c754c62d6b860acf406907c544260ff SHA512 1637d3c7aed33f4cf09a4b1de93be4b3873ceb869565137e316f3216fe6c3882d793b3303737c7f95805638b5eb1d6c3741175ffae8f026d639cbc9f9d7f1475
+EBUILD gssproxy-0.8.3.ebuild 2811 BLAKE2B ac2f788ae74a0d955b43d3037890555d63efd77c7bb10a1db00363473266e83701fe4705f8c41c56ca17b7e615b9999fc3f43bf63d9e54368360996cb440083b SHA512 495e511ae4a97144ad8567c83fa8bcb3e51b0b54cb48433d0435ae4c2cf088763541aaac5f7a3d3b1e4942fc3c5ee84759535fe0f9c33750ebf4c8f2c86988b7
MISC metadata.xml 220 BLAKE2B 8ead86e7c2e2a8ecb0068c4ebcf5322f3ccce91c48fb2bc0b62bc6400609f57b3d5c37f92351f748da0e603129fe3e7be8dfcdb6294e003bf33e3ac0ca30eb48 SHA512 c262561324e85dc1fe18ceede654af3ae9f494b36233a807944dbbc7ac9764c93654d1faf958ef4c98c1fb370c71f5073443294289f43ddee0c76e606a703d32
diff --git a/net-nds/gssproxy/gssproxy-0.8.3.ebuild b/net-nds/gssproxy/gssproxy-0.8.3.ebuild
new file mode 100644
index 000000000000..703665eae6dd
--- /dev/null
+++ b/net-nds/gssproxy/gssproxy-0.8.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="daemon to proxy GSSAPI context establishment and channel handling"
+HOMEPAGE="https://github.com/gssapi/gssproxy"
+SRC_URI="https://github.com/gssapi/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug selinux systemd hardened"
+
+COMMON_DEPEND=">=dev-libs/libverto-0.2.2
+ >=dev-libs/ding-libs-0.6.1
+ virtual/krb5
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-gssproxy )"
+# We need xml stuff to build the man pages, and people really want/need
+# the man pages for this package :). #585200
+BDEPEND="
+ app-text/docbook-xml-dtd:4.4
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# Many requirements to run tests, including running slapd as root, hence
+# unfeasible.
+RESTRICT="test"
+
+# pkg_setup() {
+# # Here instead of flag-logic in DEPEND, since virtual/krb5 does not
+# # allow to specify the openldap use flag, which heimdal doesn't
+# # support.
+# # Using mit-krb5 explicitly because heimdal doesn't install kerberos
+# # schemata required for the tests of gss-proxy.
+# if use test && ! has_version "app-crypt/mit-krb5[openldap]"; then
+# eerror "Tests of this package require the kerberos schemata installed from app-crypt/mit-krb5[openldap]."
+# die "Tests enabled but no app-crypt/mit-krb5[openldap] being installed."
+# fi
+# }
+
+# Was required in 0.7.0 to fix the schema- and slapd-path. Reason for
+# comment: see RESTRICT comment
+# src_prepare() {
+# default
+# # The tests look for kerberos schemata in the documentation
+# # directory of krb5, however these are installed in /etc/openldap
+# # and only if the openldap useflag is supplied
+# sed -i \
+# -e 's#/usr/share/doc/krb5-server-ldap*#/etc/openldap/schema#' \
+# -e "s#\(subprocess.Popen..\"\)slapd#\1/usr/$(get_libdir)/openldap/slapd#" \
+# "${S}/tests/testlib.py" || die
+# }
+
+src_configure() {
+ local myeconfargs=(
+ # The build assumes localstatedir is /var and takes care of
+ # using all the right subdirs itself.
+ "--localstatedir=${EPREFIX}/var"
+ "--with-os=gentoo"
+ "--with-initscript=$(usex systemd systemd none)"
+ "$(use_with selinux)"
+ "$(use_with debug gssidebug)"
+ "$(use_with hardened hardening)"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # This is a plugin module, so no need for la file.
+ find "${ED}"/usr -name proxymech.la -delete || die
+
+ doinitd "${FILESDIR}"/gssproxy
+ insinto /etc/gssproxy
+ doins examples/*.conf
+ insinto /etc/gss/mech.d
+ newins examples/mech gssproxy.conf
+
+ keepdir /var/lib/gssproxy
+
+ # The build installs a bunch of empty dirs, so prune them.
+ find "${ED}" -depth -type d -empty -delete || die
+}