summaryrefslogtreecommitdiff
path: root/net-nds/gssproxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /net-nds/gssproxy
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'net-nds/gssproxy')
-rw-r--r--net-nds/gssproxy/Manifest2
-rw-r--r--net-nds/gssproxy/gssproxy-0.8.4.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/net-nds/gssproxy/Manifest b/net-nds/gssproxy/Manifest
index 1b6fe13d2d7c..74ef27418a5f 100644
--- a/net-nds/gssproxy/Manifest
+++ b/net-nds/gssproxy/Manifest
@@ -1,4 +1,6 @@
AUX gssproxy 276 BLAKE2B f529b72cc589910a8c7c5f76428359e6bbca612e3ce78f1a02213655183942d1c362a3c48d7d60ceb408d4ae0a8dd75f12ebaa30d7cff59d1f0ea2537c2b1dcc SHA512 883a9a82e9f7e92aee212f9cdc8a5c5eb5204d03a928a48d5826ef4de273907a8d4f1bbf2e9351d19f88fb35cd499ea1103d7aaa0e97ed23fc2e5a0b35be0fee
DIST gssproxy-0.8.3.tar.gz 565100 BLAKE2B a8b3d96ca0b1cc314af3b63cc5959c9b48287ea0169ea75f8a8902bbd5757542fd24e1fa3f603b2a7d4c15878600145bf5a27e880e935a7a037ca3ebc9fcfb9c SHA512 144b10ec4e19ad2ded5ae57adf1ca311e2fc6c2b97e202eedde69d82c8d50afc0459ac36c7fc5d5290184eb68547a696b33e8a069fde43478104ac26b2c98bc2
+DIST gssproxy-0.8.4.tar.gz 567579 BLAKE2B 55519d2d439e168df0346cfa2655e01bc90191e17ea7d8c72c5f29c22ed6adca39e5adb4fd900f6dc756147b2fbee23212bfc097c38ab927e6c9679b0186fa2c SHA512 ab81c40d6c7b1908751feb107d8da66603b7681fb67aa7a1f30194a81d542ca89e6c2f34425e9356b9c55eb3691bfa240ba41441c01498af45e862a133cd088a
EBUILD gssproxy-0.8.3.ebuild 2807 BLAKE2B fd06a46cd3fd392ef0e75a2a5b6599d65289a88b1cbde9c76776258fc6eabcea6df888ab8d7c8dca2c275691f63a155c9ed89c0d40726b95331e7e58b30b78b8 SHA512 0e0b49feb105c9dae277ea23ccfd3ce36fd4b32781c1109ff996c7ae491857b92495e47af4b0c9d293c62a5f5449b9ccc584f7dd2104ff3ae7907b9b35b94696
+EBUILD gssproxy-0.8.4.ebuild 2811 BLAKE2B b0a0526c2bdcd5ef3a94eda01b64b869c4bd52f0faf9c52ec07936daff637fc35c4172df1e9b71fa9b14dbd4b93b5557d5c79eb6f16f5b3ffe3c176c35e0d211 SHA512 8d53fc9fe17f99356bb2f2ce6af89ddbc973b5a0dee691cc75c6bf80178efc0acfb37a992eb684508aab6748f6e2030cdeb27d8de80de4d2aec5d906fe61a9b5
MISC metadata.xml 220 BLAKE2B 8ead86e7c2e2a8ecb0068c4ebcf5322f3ccce91c48fb2bc0b62bc6400609f57b3d5c37f92351f748da0e603129fe3e7be8dfcdb6294e003bf33e3ac0ca30eb48 SHA512 c262561324e85dc1fe18ceede654af3ae9f494b36233a807944dbbc7ac9764c93654d1faf958ef4c98c1fb370c71f5073443294289f43ddee0c76e606a703d32
diff --git a/net-nds/gssproxy/gssproxy-0.8.4.ebuild b/net-nds/gssproxy/gssproxy-0.8.4.ebuild
new file mode 100644
index 000000000000..5bb81004b8fc
--- /dev/null
+++ b/net-nds/gssproxy/gssproxy-0.8.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="daemon to proxy GSSAPI context establishment and channel handling"
+HOMEPAGE="https://github.com/gssapi/gssproxy"
+SRC_URI="https://github.com/gssapi/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug selinux systemd hardened"
+
+COMMON_DEPEND=">=dev-libs/libverto-0.2.2
+ >=dev-libs/ding-libs-0.6.1
+ virtual/krb5
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-gssproxy )"
+# We need xml stuff to build the man pages, and people really want/need
+# the man pages for this package :). #585200
+BDEPEND="
+ app-text/docbook-xml-dtd:4.4
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# Many requirements to run tests, including running slapd as root, hence
+# unfeasible.
+RESTRICT="test"
+
+# pkg_setup() {
+# # Here instead of flag-logic in DEPEND, since virtual/krb5 does not
+# # allow to specify the openldap use flag, which heimdal doesn't
+# # support.
+# # Using mit-krb5 explicitly because heimdal doesn't install kerberos
+# # schemata required for the tests of gss-proxy.
+# if use test && ! has_version "app-crypt/mit-krb5[openldap]"; then
+# eerror "Tests of this package require the kerberos schemata installed from app-crypt/mit-krb5[openldap]."
+# die "Tests enabled but no app-crypt/mit-krb5[openldap] being installed."
+# fi
+# }
+
+# Was required in 0.7.0 to fix the schema- and slapd-path. Reason for
+# comment: see RESTRICT comment
+# src_prepare() {
+# default
+# # The tests look for kerberos schemata in the documentation
+# # directory of krb5, however these are installed in /etc/openldap
+# # and only if the openldap useflag is supplied
+# sed -i \
+# -e 's#/usr/share/doc/krb5-server-ldap*#/etc/openldap/schema#' \
+# -e "s#\(subprocess.Popen..\"\)slapd#\1/usr/$(get_libdir)/openldap/slapd#" \
+# "${S}/tests/testlib.py" || die
+# }
+
+src_configure() {
+ local myeconfargs=(
+ # The build assumes localstatedir is /var and takes care of
+ # using all the right subdirs itself.
+ "--localstatedir=${EPREFIX}/var"
+ "--with-os=gentoo"
+ "--with-initscript=$(usex systemd systemd none)"
+ "$(use_with selinux)"
+ "$(use_with debug gssidebug)"
+ "$(use_with hardened hardening)"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # This is a plugin module, so no need for la file.
+ find "${ED}"/usr -name proxymech.la -delete || die
+
+ doinitd "${FILESDIR}"/gssproxy
+ insinto /etc/gssproxy
+ doins examples/*.conf
+ insinto /etc/gss/mech.d
+ newins examples/mech gssproxy.conf
+
+ keepdir /var/lib/gssproxy
+
+ # The build installs a bunch of empty dirs, so prune them.
+ find "${ED}" -depth -type d -empty -delete || die
+}