summaryrefslogtreecommitdiff
path: root/net-nds/gssproxy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /net-nds/gssproxy
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'net-nds/gssproxy')
-rw-r--r--net-nds/gssproxy/Manifest2
-rw-r--r--net-nds/gssproxy/gssproxy-0.9.1.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/net-nds/gssproxy/Manifest b/net-nds/gssproxy/Manifest
index 2e521ff6fb6a..665d3483eeb6 100644
--- a/net-nds/gssproxy/Manifest
+++ b/net-nds/gssproxy/Manifest
@@ -1,5 +1,7 @@
AUX gssproxy 371 BLAKE2B d51ab4a06138dcc4af7b1706948534bd3b0b0fe1e715085eeb910bfacab9bb9d46af132901d9ed59feaab889409f917c72527377cf233ddce928e02a287bea99 SHA512 ec7b7e6684ed93ec6a71d5c4bfef7f6a6a61b22202607064e906165e1b5a14f283476d25ef19551040b462f173352ce330a3781b20d0865d4799f087cd707c28
AUX gssproxy-0.8.4-include.patch 637 BLAKE2B 072df0a6cd7aa8f145babb37b055761ef93c472708decbbcd5ac8e130becab1eb44b4b01a3d5b1aaaea76ad02931c1f7ad5100b8fbe4b4bcdf784bfa75e8642b SHA512 5520670fbefa5e354f707ba186055db076abcdacd6b099c129de263d6dfc27da10d8d5a5142fb3414c0d37e62a68af1f169dab862a97e14f9b1146d25fd1e169
DIST gssproxy-0.8.4.tar.gz 567579 BLAKE2B 55519d2d439e168df0346cfa2655e01bc90191e17ea7d8c72c5f29c22ed6adca39e5adb4fd900f6dc756147b2fbee23212bfc097c38ab927e6c9679b0186fa2c SHA512 ab81c40d6c7b1908751feb107d8da66603b7681fb67aa7a1f30194a81d542ca89e6c2f34425e9356b9c55eb3691bfa240ba41441c01498af45e862a133cd088a
+DIST gssproxy-0.9.1.tar.gz 579038 BLAKE2B a17e673876b4acf480b23a8086720f507cd3a85c2f328469b726ab1653a94cd9a3eb9dd9369dee30b57457b6e8125b67a86fc4186c387e58d2d96b1da7c55089 SHA512 767c4e73d5240a43a0586e836e7dc199b8baf0adbc5a1a2cbb6ffc6f0a7ca574a4fc541ca474ef696d78956724eb24c465760f680e7170f8d77d056513b6226b
EBUILD gssproxy-0.8.4-r2.ebuild 3000 BLAKE2B 87c4431a8cde813bbfcfcbf1d56d2b83548c787078091e64c1a2fc374f5e3fff88dee985d96f20bf2b30b2b20b36cb74da9efa489b6be65afeb9f4b187c1753f SHA512 9242a135a397c375bf37a196ebc74f4475d65788a6989ea6e7578fec65cfeb17b4f8d7e3fe69ebcfd47fe2971d9cfba1690bd5d3bcc2ceeddd943fc40e20e579
+EBUILD gssproxy-0.9.1.ebuild 3169 BLAKE2B fe6e21628f8d15ea5d9163d7a11388c2582fc02851068c4160a2f63a3f28c66d0a2ee95419c6d1e59f5ae250c0aae0ff67b9e5fc932d780c45adc47e5614f790 SHA512 7306fb1491516a975d4d449c645db35ed8df79756632f22fb2237a804de3da2530b2d2756c07a1ba3beae2dc28f85ff1665ba2d6d5fc7f4dc5ade8b482cd03fd
MISC metadata.xml 221 BLAKE2B 12ca7879e624ddb2085fbcf6c64b392796ef63aa3542bb51f80594cb6f319c2e7cc52660108a94f81ce540a19b07607ac599e82a21c4b5a46ccbf983c5d38d3b SHA512 c67d921bc7074f20a036d795b10293f39a9a2d6d21ccbbeee776a6ceff36d0e89f15bb98f6761de93f290addbf1447fddd20de80cec60c0987913d47e976ef61
diff --git a/net-nds/gssproxy/gssproxy-0.9.1.ebuild b/net-nds/gssproxy/gssproxy-0.9.1.ebuild
new file mode 100644
index 000000000000..674911d1cefd
--- /dev/null
+++ b/net-nds/gssproxy/gssproxy-0.9.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Daemon to proxy GSSAPI context establishment and channel handling"
+HOMEPAGE="https://github.com/gssapi/gssproxy"
+SRC_URI="https://github.com/gssapi/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug selinux systemd"
+
+COMMON_DEPEND=">=dev-libs/libverto-0.2.2
+ >=dev-libs/ding-libs-0.6.1
+ virtual/krb5
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-gssproxy )"
+# We need xml stuff to build the man pages, and people really want/need
+# the man pages for this package :). #585200
+BDEPEND="
+ app-text/docbook-xml-dtd:4.4
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+
+# Many requirements to run tests, including running slapd as root, hence
+# unfeasible.
+RESTRICT="test"
+
+# pkg_setup() {
+# # Here instead of flag-logic in DEPEND, since virtual/krb5 does not
+# # allow to specify the openldap use flag, which heimdal doesn't
+# # support.
+# # Using mit-krb5 explicitly because heimdal doesn't install kerberos
+# # schemata required for the tests of gss-proxy.
+# if use test && ! has_version "app-crypt/mit-krb5[openldap]"; then
+# eerror "Tests of this package require the kerberos schemata installed from app-crypt/mit-krb5[openldap]."
+# die "Tests enabled but no app-crypt/mit-krb5[openldap] being installed."
+# fi
+# }
+
+# Was required in 0.7.0 to fix the schema- and slapd-path. Reason for
+# comment: see RESTRICT comment
+# src_prepare() {
+# default
+# # The tests look for kerberos schemata in the documentation
+# # directory of krb5, however these are installed in /etc/openldap
+# # and only if the openldap useflag is supplied
+# sed -i \
+# -e 's#/usr/share/doc/krb5-server-ldap*#/etc/openldap/schema#' \
+# -e "s#\(subprocess.Popen..\"\)slapd#\1/usr/$(get_libdir)/openldap/slapd#" \
+# "${S}/tests/testlib.py" || die
+# }
+
+src_configure() {
+ local myeconfargs=(
+ # The build assumes localstatedir is /var and takes care of
+ # using all the right subdirs itself.
+ --localstatedir="${EPREFIX}"/var
+
+ --with-os=gentoo
+ --with-initscript=$(usex systemd systemd none)
+ $(use_with selinux)
+ $(use_with debug gssidebug)
+
+ # We already set FORTIFY_SOURCE by default along with the
+ # other bits. But setting it on each compile line interferes
+ # with efforts to try e.g. FORTIFY_SOURCE=3. So, disable it,
+ # but there's no actual difference to the safety of the binaries
+ # because of Gentoo's configuration/patches to the toolchain.
+ --without-hardening
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # This is a plugin module, so no need for la file.
+ find "${ED}"/usr -name proxymech.la -delete || die
+
+ doinitd "${FILESDIR}"/gssproxy
+ insinto /etc/gssproxy
+ doins examples/*.conf
+
+ keepdir /var/lib/gssproxy
+ keepdir /var/lib/gssproxy/clients
+ keepdir /var/lib/gssproxy/rcache
+ fperms 0700 /var/lib/gssproxy/clients
+ fperms 0700 /var/lib/gssproxy/rcache
+
+ # The build installs a bunch of empty dirs, so prune them.
+ find "${ED}" -depth -type d -empty -delete || die
+}