summaryrefslogtreecommitdiff
path: root/net-misc/ytmdl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-27 16:00:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-27 16:00:10 +0100
commit9f51c386724b9543e88a9c0e1be57d44326f3116 (patch)
treed351bdf5964a53a79ca2c9cec1123b234cd321ed /net-misc/ytmdl
parentfdfde9fd41778789aaab6711adb9e4cc31c28360 (diff)
gentoo auto-resync : 27:08:2023 - 16:00:10
Diffstat (limited to 'net-misc/ytmdl')
-rw-r--r--net-misc/ytmdl/Manifest2
-rw-r--r--net-misc/ytmdl/ytmdl-2023.7.27.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/ytmdl/Manifest b/net-misc/ytmdl/Manifest
index e2f8f838d46d..e645b76b6b50 100644
--- a/net-misc/ytmdl/Manifest
+++ b/net-misc/ytmdl/Manifest
@@ -1,3 +1,5 @@
DIST ytmdl-2023.2.28.tar.gz 52281 BLAKE2B 5a9dfea6022082b976fb165ca45cb4ae13adac9308cb5671b52bd433eed4b2921bad345c3acaa10f125d06162964c55b82c44468e3d12b52c47ea63d2d1bce71 SHA512 891119c0386bd2079108b9b34f41606c2a6da21de5f574a89b95d6cb5a661611e442ffc10f6f4d94d827318568408ff8d5b58eb3eb602e64afa4efa3728b3855
+DIST ytmdl-2023.7.27.tar.gz 53737 BLAKE2B 8f01a8cd9b666904fe29871f5f595bae8dd0d29741c5e7c77886d0444a9b23fbf99e1c0efdadb3a62fa0c37425271724327ad655bd2bfb9a53b81a3cf4705289 SHA512 b300590f1aae0378c3672df24b766c6729b034711f83102881f0bd81d7d383825f3187c6f28611c38ad634542b8eb4bbe2c4fcb8a946b7eef9be492a3bfee927
EBUILD ytmdl-2023.2.28.ebuild 1245 BLAKE2B 6a5a3f93767d8fe06d844243aeed742859b05d36e6fb34f4f9b3785d9168248ebfef07fd3ba1482863d7c6556464a39da5b4c1ee2342494d094b511322c1cfea SHA512 ca34a5fbdf8e2f967571a3e83b6f0e73a06c9930f1d11b84e349ac9d5fd537ae42a7aeadb6d3476136342085582b5344fd8b2ce3807d06221ff88256f4a004a2
+EBUILD ytmdl-2023.7.27.ebuild 1285 BLAKE2B 4f66ff47ac18acc842568785995eee1440017bdf356cf218fba815415cb655e0c1402829387e3f9e59144f0473cb74a454d010a9d2ea6fc3dad0cf77cc017b7c SHA512 d20b1ea5bd6dfc077cc22d66f3afdfd8b9f24fe0122036424f11db7b1dfa517c8581b386343a38fffc43380e2e835ad6f2a3ec70d5ea05df455185b56561b1ec
MISC metadata.xml 450 BLAKE2B 9901cfebf346a8874315680cdef3ff19d49a84a812358aa122b99645ccde78f8c3b3ea42b1d16bdfcf9f670a694ebcbd9ce50cbcaefcef11c97eeee85264b442 SHA512 32a761ea39aaf5654523a09bfd5bfc6f4052cd35248439bb46175409085cb13b5fbb0097269785ae11df5701fa785ee564d756af5b00b4ab8112cdf3381f45e3
diff --git a/net-misc/ytmdl/ytmdl-2023.7.27.ebuild b/net-misc/ytmdl/ytmdl-2023.7.27.ebuild
new file mode 100644
index 000000000000..2f403c684fdf
--- /dev/null
+++ b/net-misc/ytmdl/ytmdl-2023.7.27.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Simple app to get songs from youtube in mp3 format"
+HOMEPAGE="https://ytmdl.deepjyoti30.dev/
+ https://github.com/deepjyoti30/ytmdl/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=net-misc/yt-dlp-2022.3.8.2[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/ffmpeg-python[${PYTHON_USEDEP}]
+ dev-python/itunespy[${PYTHON_USEDEP}]
+ dev-python/pyDes[${PYTHON_USEDEP}]
+ dev-python/python-musicbrainzngs[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ dev-python/simber[${PYTHON_USEDEP}]
+ dev-python/spotipy[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/youtube-search-python[${PYTHON_USEDEP}]
+ dev-python/ytmusicapi[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ net-misc/downloader-cli[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp ${PN}.bash ${PN}
+}