summaryrefslogtreecommitdiff
path: root/net-misc/ytfzf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-12 22:42:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-12 22:42:36 +0100
commitd24a417ad25a06bbd0cb13469ec2278ae8f33fba (patch)
tree0264a09107d206a9493e44fd90c554f402142072 /net-misc/ytfzf
parentd4de2b287be5b8553180509934fd44ef3d7fce3c (diff)
gentoo auto-resync : 12:09:2023 - 22:42:36
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest2
-rw-r--r--net-misc/ytfzf/ytfzf-2.6.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index c3b2db72acc9..f7556cad4d5f 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1,3 +1,5 @@
DIST ytfzf-2.6.0.tar.gz 3277853 BLAKE2B f99de6c473ee728d42290a647df9e0404dea92854203f306401d916e920814517dee3ddde8c8ff06cb7ff29f5a9b8f438867a1d9bc02aa6e208d030ad8b786a7 SHA512 fb9a1bd161a735a9c464948d6ba3664982eadd25456d5d565c57e478574949324dbf556620fb837c00bc4946c65336ec895f7c59e1169631effadf70085773c4
+DIST ytfzf-2.6.1.tar.gz 3278989 BLAKE2B 85ad83d9880e3e9e02a9a22b9f15e9ce88fafb1466f1694bd05766b24ac4505ce7da61e391d18f2973695394b89f5e4581f1c9e6588a6783a6fefa7adfaf7c67 SHA512 9266065352ae797bd5b8a2c71681b15599347ca38a519a21e84b42a0e8bb102c0937a02cbd6027c736ac0bdd7a6bc67fea664ecce5698032b4fef1ef0ec92c65
EBUILD ytfzf-2.6.0.ebuild 1380 BLAKE2B e9fa39dcabf24063ab3c0ef4a0e0ff5f999b14f13f06839581db6b2a9219a47b7da9f3474cacecf8d215c61fd9cb1f216f549320004d1d7d6ac59c3e1f0871ac SHA512 b80d0656aba48fe99a2075c6a42dd8a4ca92a723483fb7b74f9e80d1aff1e47b98ccccaaa2457229b0f3e44bd7895394dd162987969e90e6e662cacbbe5740eb
+EBUILD ytfzf-2.6.1.ebuild 1383 BLAKE2B 3d8b09a6c2c22a75378972fd63d303fe8c50b9d7cb9c34ef78ac9494e80007c15f55529455cd19ddace0ce8b2fc163463f868120e71fba2c0dfbf7c12f3e37fc SHA512 654d5f3bcdf650943041c79e072b28035009bc3a34177b25450d34a9915c4a5eadad68aeaf65bcc6a27509941999c13e57c101c643a1bd148ac27da29cf0d6c4
MISC metadata.xml 650 BLAKE2B cef000d14639ebedc5583c42fc5ec8ea62307702ee1ca01272356a4aea375a464d0c0a24bedff98e38e16133161d09864e4c4875e7ecbad96b1611aebe0924e5 SHA512 61b25935bb80c572023948e49bfd3c8bf7551e94f0cc36592049f03498557c165f3c64815c41067ae85823254e578134770a235072254fd9e2e7ad06956c9b2f
diff --git a/net-misc/ytfzf/ytfzf-2.6.1.ebuild b/net-misc/ytfzf/ytfzf-2.6.1.ebuild
new file mode 100644
index 000000000000..805a4b1030fa
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.6.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal +thumbnails"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ app-alternatives/awk
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ thumbnails? (
+ || (
+ media-gfx/ueberzugpp
+ media-gfx/ueberzug
+ )
+ )
+ )
+"
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}