summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-03 08:05:42 +0100
commit8435c842b9e8fbb2bcc80397ab3aa655000459e2 (patch)
treeb74558e80643a8f074c501e8b4bf7f50f7155455 /net-misc/yt-dlp
parent5c5e9714c851027611cb726a76ebb8be6d48cbdc (diff)
gentoo auto-resync : 03:07:2024 - 08:05:42
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest2
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.07.02.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index d0d676b5aa1e..225901922a67 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,4 +1,6 @@
DIST yt-dlp-2024.07.01.tar.gz 5667870 BLAKE2B fec104c68ac2a465370a6c4270154fd18f496e0ed319c8b2a1a48cb43d8ba55f438f3b83182a8feece23d36aea180ba2f00412872cad92afab5be7ce46480e44 SHA512 1b99d82eb838fb654082c8bad7bdbd87ed2cdf3d80f38288eb1cf7f7112981eb5f45b6fc7cf861d7b10cec89626a2a7bebf20d32ba53b9dcb5d37275e3f02d6f
+DIST yt-dlp-2024.07.02.tar.gz 5671980 BLAKE2B 63fd9a938fe1a07de7c9a762f42a1276260dc5c7c248c0a8b32953cd6184978e691aa778fa98eb0175f48dc6692793f85fac04decbdffec7f9bd637e2b4ee842 SHA512 7b9c41a5dccaf9188680cac88010b7695e0809f2b3cdea398af3c507717634067e8f9d0fe02f4d51828c026bce5a31d0ae2b89a2bcc83f51ca703b627dbb995e
EBUILD yt-dlp-2024.07.01.ebuild 2269 BLAKE2B eb46ced81ec2279b0566c33f5b3b0e2128ba8a28404c54154eb3a69a365d302881b230b31ac0a97901f0772ece54ac7bd4c6a20d828b61bf7dd1e87144753ce4 SHA512 a9a4c068f027e9fe169e6a7fc9656ad68d2cab8543f85e47f2b045025f3b14d60b20ac42cb571c7e663ec661e3713aeb86d72d9afb04002b96a63d8f8d896ff7
+EBUILD yt-dlp-2024.07.02.ebuild 2269 BLAKE2B eb46ced81ec2279b0566c33f5b3b0e2128ba8a28404c54154eb3a69a365d302881b230b31ac0a97901f0772ece54ac7bd4c6a20d828b61bf7dd1e87144753ce4 SHA512 a9a4c068f027e9fe169e6a7fc9656ad68d2cab8543f85e47f2b045025f3b14d60b20ac42cb571c7e663ec661e3713aeb86d72d9afb04002b96a63d8f8d896ff7
EBUILD yt-dlp-9999.ebuild 2436 BLAKE2B 3be5da21d8b1ffef30cb8c204121d7c7ce59ca12d0e369ce6c232dba59a1cf8c057c7f6b09b6bca4289533f04db6075c72843d5154221b0c8f18dd6cea809d4f SHA512 c83a141c85ac1fb1091525f6f3b7600d3fc9132b2a4cff39f5460fb2c20c5d9094e2176450cdcde24b05877c2306462045929ea6e3690d9d48012e234a8381ca
MISC metadata.xml 392 BLAKE2B d2aa6fc43f7f9038d320197a18107f15e56ed5e242e6c3cdc1b7111184580ab14fae8cbd16776794d207dd39ea0ca65975c08a54449f4cf90370ea95a66083d9 SHA512 867c61c1e41d7594decd5e10a2b45d934313cb751ba22356fc1ab61e0a40b2543847b195d20c7a39ba92370d8b3908e6f90d690915579b55808872efe8d3cebe
diff --git a/net-misc/yt-dlp/yt-dlp-2024.07.02.ebuild b/net-misc/yt-dlp/yt-dlp-2024.07.02.ebuild
new file mode 100644
index 000000000000..68214ba4c2eb
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.07.02.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}